KNOWNHOST WIKI

User Tools

Site Tools


control-panels:cpanel-whm:how-to-use-easyapache4

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
control-panels:cpanel-whm:how-to-use-easyapache4 [2019/10/10 15:19]
Karson N.
control-panels:cpanel-whm:how-to-use-easyapache4 [2020/06/16 14:13] (current)
Karson N.
Line 11: Line 11:
 You can quick-jump to any section in which you want to check over utilizing the contents listing on the right hand side of this page. You can quick-jump to any section in which you want to check over utilizing the contents listing on the right hand side of this page.
  
 +\\
 ===== How to get to EasyApache 4 within WHM ===== ===== How to get to EasyApache 4 within WHM =====
  
 First; we're going to want to get to EasyApache 4; so let's begin First; we're going to want to get to EasyApache 4; so let's begin
  
 +\\
 **Step 1. Login to WHM!** (Remember: The username for WHM is always 'root') **Step 1. Login to WHM!** (Remember: The username for WHM is always 'root')
  
 {{:control-panels:cpanel-whm:whm-0.png?nolink&500|}} {{:control-panels:cpanel-whm:whm-0.png?nolink&500|}}
 +----
  
 +\\
 **Step 2. Get to EasyApache 4** **Step 2. Get to EasyApache 4**
  
Line 25: Line 29:
 __Method 1: Click 'Classic' then "Software".__ __Method 1: Click 'Classic' then "Software".__
  
-{{:control-panels:cpanel-whm:whm-1.png?nolink&800|}}+{{:control-panels:cpanel-whm:whm-1.png?nolink&1200|}} 
 +----
  
 You'll want to then click EasyApache 4 You'll want to then click EasyApache 4
  
-{{:control-panels:cpanel-whm:whm-1-1.png?nolink&800|}}+{{:control-panels:cpanel-whm:whm-1-1.png?nolink&1200|}} 
 +----
  
 __Method 2: If you're in the new WHM look; you can use the search bar (works for both versions) and type "EasyApache 4"__ __Method 2: If you're in the new WHM look; you can use the search bar (works for both versions) and type "EasyApache 4"__
  
-{{:control-panels:cpanel-whm:whm-2.png?nolink&800|}}+{{:control-panels:cpanel-whm:whm-2.png?nolink&1200|}} 
 +----
  
 +\\
 **Step 3: Click EasyApache 4, whichever method you used!** **Step 3: Click EasyApache 4, whichever method you used!**
  
 This takes you to the EasyApache 4 GUI Interface. This takes you to the EasyApache 4 GUI Interface.
  
-{{:control-panels:cpanel-whm:whm-3.png?nolink&800|}}+{{:control-panels:cpanel-whm:whm-3.png?nolink&1200|}} 
 +----
  
 You'll see a section called "Currently Installed Packages"  You'll see a section called "Currently Installed Packages" 
Line 45: Line 54:
 This section lists what's currently installed to the profile; for this server it's the following: This section lists what's currently installed to the profile; for this server it's the following:
  
 +\\
 ** Contains Apache 2.4, PHP 5.6, PHP 7.0, PHP 7.2, and PHP 7.3**  ** Contains Apache 2.4, PHP 5.6, PHP 7.0, PHP 7.2, and PHP 7.3** 
  
Line 59: Line 69:
 In order to adjust your profile -- you would click "Customize"; do note after clicking "Customize" this can take awhile to load, but once it does you'll see the middle section which displays module information, and on the left hand side you'll see "Apache MPM, Apache Modules, PHP Versions, etc" In order to adjust your profile -- you would click "Customize"; do note after clicking "Customize" this can take awhile to load, but once it does you'll see the middle section which displays module information, and on the left hand side you'll see "Apache MPM, Apache Modules, PHP Versions, etc"
  
-{{:control-panels:cpanel-whm:whm-3-1.png?nolink&800|}}+{{:control-panels:cpanel-whm:whm-3-1.png?nolink&1200|}} 
 +----
  
 +\\
 ===== Apache for EA 4 ===== ===== Apache for EA 4 =====
  
Line 69: Line 81:
 In order to adjust the Apache MPM; you'll want to be in the Apache MPM section of EasyApache 4 In order to adjust the Apache MPM; you'll want to be in the Apache MPM section of EasyApache 4
  
-{{:control-panels:cpanel-whm:whm-0-1.png?nolink&800|}}+{{:control-panels:cpanel-whm:whm-0-1.png?nolink&1200|}} 
 +----
  
 There are multiple MPM's to choose from. Our default and recommended is mpm_prefork; but we have some that use mpm_worker There are multiple MPM's to choose from. Our default and recommended is mpm_prefork; but we have some that use mpm_worker
  
-<WRAP center round important 40%>+<WRAP center round important 50%>
 **mpm_event is not currently recommended for production environment use unless you know what you are doing!** **mpm_event is not currently recommended for production environment use unless you know what you are doing!**
 </WRAP> </WRAP>
Line 79: Line 92:
 For this reason; if you feel like you need to adjust MPM modules or have questions, please submit a support ticket! For this reason; if you feel like you need to adjust MPM modules or have questions, please submit a support ticket!
  
 +\\
 ==== Apache Modules ==== ==== Apache Modules ====
  
 Configuring Apache modules is just as easy as everything else in EasyApache 4; due to the RPM based system -- this is just toggling to enable/disable as necessary. Configuring Apache modules is just as easy as everything else in EasyApache 4; due to the RPM based system -- this is just toggling to enable/disable as necessary.
  
-{{:control-panels:cpanel-whm:whm-0-2.png?nolink&800|}}+{{:control-panels:cpanel-whm:whm-0-2.png?nolink&1200|}} 
 +----
  
 You can use the search bar to search for specific modules that you need; in our example we use 'lsapi' You can use the search bar to search for specific modules that you need; in our example we use 'lsapi'
  
-{{:control-panels:cpanel-whm:whm-0-3.png?nolink&800|}}+{{:control-panels:cpanel-whm:whm-0-3.png?nolink&1200|}} 
 +----
  
 In this case 'mod_lsapi' is already installed, so we don't need to do anything. In this case 'mod_lsapi' is already installed, so we don't need to do anything.
Line 95: Line 111:
 This same process would be used for any other additional Apache modules you wanted to build/include to your server. This same process would be used for any other additional Apache modules you wanted to build/include to your server.
  
 +\\
 ===== PHP Versions for EA 4 ===== ===== PHP Versions for EA 4 =====
  
Line 105: Line 122:
 You'll click "PHP Versions" -- you can then toggle the switch to install or remove PHP versions.  You'll click "PHP Versions" -- you can then toggle the switch to install or remove PHP versions. 
  
-{{:control-panels:cpanel-whm:whm-3-2.png?nolink&800|}}+{{:control-panels:cpanel-whm:whm-3-2.png?nolink&1200|}} 
 +----
  
 When you toggle a PHP version to install; it's going to ask you if you want the PHP version alone or if you want the extensions with it. When you toggle a PHP version to install; it's going to ask you if you want the PHP version alone or if you want the extensions with it.
Line 111: Line 129:
 It's best to get it with the extensions so that you don't miss anything. It's best to get it with the extensions so that you don't miss anything.
  
-{{:control-panels:cpanel-whm:whm-3-3.png?nolink&800|}}+{{:control-panels:cpanel-whm:whm-3-3.png?nolink&1200|}} 
 +----
  
 When you toggle a PHP version to uninstall/remove -- **if there are websites assigned to it; you must remove them from that version first!** When you toggle a PHP version to uninstall/remove -- **if there are websites assigned to it; you must remove them from that version first!**
Line 117: Line 136:
 Otherwise; it'll turn 'yellow' around the outline to indicate removal. Otherwise; it'll turn 'yellow' around the outline to indicate removal.
  
-{{:control-panels:cpanel-whm:whm-3-4.png?nolink&800|}}+{{:control-panels:cpanel-whm:whm-3-4.png?nolink&1200|}} 
 +----
  
 If you don't need any PHP Modules; skip to the [[control-panels:cpanel-whm:how-to-use-easyapache4#review_your_changes|review changes]]! If you don't need any PHP Modules; skip to the [[control-panels:cpanel-whm:how-to-use-easyapache4#review_your_changes|review changes]]!
  
 +\\
 ===== PHP Extensions for EA 4 ===== ===== PHP Extensions for EA 4 =====
  
Line 128: Line 148:
 You'll want to click the PHP Extensions section on the left-hand menu; you'll be brought to the PHP Extensions area. You'll want to click the PHP Extensions section on the left-hand menu; you'll be brought to the PHP Extensions area.
  
-{{:control-panels:cpanel-whm:whm-5-1.png?nolink&800|}}+{{:control-panels:cpanel-whm:whm-5-1.png?nolink&1200|}} 
 +----
  
 You'll see a page displayed for extensions with your PHP versions listed at the top. You'll see a page displayed for extensions with your PHP versions listed at the top.
  
-{{:control-panels:cpanel-whm:whm-5-2.png?nolink&800|}}+{{:control-panels:cpanel-whm:whm-5-2.png?nolink&1200|}} 
 +----
  
 You can deselect to have the page display only modules for specific PHP versions to help isolate what versions you need. You can deselect to have the page display only modules for specific PHP versions to help isolate what versions you need.
  
-Alternativelyyou can use the search bar if you know the specific module you want and it'll show it for all installed versions of PHP. +**Alternatively:** you can use the search bar if you know the specific module you want and it'll show it for all installed versions of PHP. 
  
 In this example we will use 'opcache' In this example we will use 'opcache'
  
-{{:control-panels:cpanel-whm:whm-5-3.png?nolink&800|}}+{{:control-panels:cpanel-whm:whm-5-3.png?nolink&1200|}} 
 +----
  
 You can see that I've entered 'opcache' and the results for each PHP version have been shown. You can see that I've entered 'opcache' and the results for each PHP version have been shown.
Line 148: Line 171:
 If you were logged to remove it; you would just untoggle it and continue on to the "Review" section to provision your changes. If you were logged to remove it; you would just untoggle it and continue on to the "Review" section to provision your changes.
  
 +\\
 ===== Review your changes ===== ===== Review your changes =====
  
Line 154: Line 178:
 In this example; we installed PHP 7.1. In this example; we installed PHP 7.1.
  
-{{:control-panels:cpanel-whm:whm-4.png?nolink&800|}}+{{:control-panels:cpanel-whm:whm-4.png?nolink&1200|}} 
 +----
  
 Confirm these are what you intend to add and scroll to the very bottom and click 'Provision' Confirm these are what you intend to add and scroll to the very bottom and click 'Provision'
  
-{{:control-panels:cpanel-whm:whm-4-1.png?nolink&800|}}+{{:control-panels:cpanel-whm:whm-4-1.png?nolink&1200|}}
  
-{{:control-panels:cpanel-whm:whm-4-2.png?nolink&800|}}+{{:control-panels:cpanel-whm:whm-4-2.png?nolink&1200|}} 
 +----
  
 You'll see a quick install page where a series of outputs will be provided to you. You'll see a quick install page where a series of outputs will be provided to you.
Line 168: Line 194:
 <code> <code>
                     Provision process started.                     Provision process started.
-[2019-04-19 07:42:35 -0500] info [xml-api]   +  [2019-04-19 07:42:35 -0500] info [xml-api]   
-[2019-04-19 07:42:35 -0500] info [xml-api]   Verifying  : ea-php71-7.1.28-1.1.1.cpanel.x86_64                         1/10  +  [2019-04-19 07:42:35 -0500] info [xml-api]   Verifying  : ea-php71-7.1.28-1.1.1.cpanel.x86_64                         1/10  
-[2019-04-19 07:42:35 -0500] info [xml-api]   Verifying  : ea-php71-pear-1.10.7-1.1.9.cpanel.noarch                    2/10  +  [2019-04-19 07:42:35 -0500] info [xml-api]   Verifying  : ea-php71-pear-1.10.7-1.1.9.cpanel.noarch                    2/10  
-[2019-04-19 07:42:35 -0500] info [xml-api]   Verifying  : ea-php71-php-xml-7.1.28-1.1.1.cpanel.x86_64                 3/10  +  [2019-04-19 07:42:35 -0500] info [xml-api]   Verifying  : ea-php71-php-xml-7.1.28-1.1.1.cpanel.x86_64                 3/10  
-[2019-04-19 07:42:35 -0500] info [xml-api]   Verifying  : ea-php71-php-litespeed-7.1.28-1.1.1.cpanel.x86_64           4/10  +  [2019-04-19 07:42:35 -0500] info [xml-api]   Verifying  : ea-php71-php-litespeed-7.1.28-1.1.1.cpanel.x86_64           4/10  
-[2019-04-19 07:42:35 -0500] info [xml-api]   Verifying  : ea-php71-php-devel-7.1.28-1.1.1.cpanel.x86_64               5/10  +  [2019-04-19 07:42:35 -0500] info [xml-api]   Verifying  : ea-php71-php-devel-7.1.28-1.1.1.cpanel.x86_64               5/10  
-[2019-04-19 07:42:35 -0500] info [xml-api]   Verifying  : ea-php71-php-posix-7.1.28-1.1.1.cpanel.x86_64               6/10  +  [2019-04-19 07:42:35 -0500] info [xml-api]   Verifying  : ea-php71-php-posix-7.1.28-1.1.1.cpanel.x86_64               6/10  
-[2019-04-19 07:42:35 -0500] info [xml-api]   Verifying  : ea-php71-php-common-7.1.28-1.1.1.cpanel.x86_64              7/10  +  [2019-04-19 07:42:35 -0500] info [xml-api]   Verifying  : ea-php71-php-common-7.1.28-1.1.1.cpanel.x86_64              7/10  
-[2019-04-19 07:42:35 -0500] info [xml-api]   Verifying  : ea-php71-php-cli-7.1.28-1.1.1.cpanel.x86_64                 8/10  +  [2019-04-19 07:42:35 -0500] info [xml-api]   Verifying  : ea-php71-php-cli-7.1.28-1.1.1.cpanel.x86_64                 8/10  
-[2019-04-19 07:42:35 -0500] info [xml-api]   Verifying  : ea-php71-runtime-7.1.28-1.1.1.cpanel.x86_64                 9/10  +  [2019-04-19 07:42:35 -0500] info [xml-api]   Verifying  : ea-php71-runtime-7.1.28-1.1.1.cpanel.x86_64                 9/10  
-[2019-04-19 07:42:35 -0500] info [xml-api]   Verifying  : ea-php71-php-ftp-7.1.28-1.1.1.cpanel.x86_64                10/10  +  [2019-04-19 07:42:35 -0500] info [xml-api]   Verifying  : ea-php71-php-ftp-7.1.28-1.1.1.cpanel.x86_64                10/10  
-[2019-04-19 07:42:35 -0500] info [xml-api] Installed: +  [2019-04-19 07:42:35 -0500] info [xml-api] Installed: 
-[2019-04-19 07:42:35 -0500] info [xml-api]   ea-php71.x86_64 0:7.1.28-1.1.1.cpanel                                          +  [2019-04-19 07:42:35 -0500] info [xml-api]   ea-php71.x86_64 0:7.1.28-1.1.1.cpanel                                          
-[2019-04-19 07:42:35 -0500] info [xml-api]   ea-php71-pear.noarch 0:1.10.7-1.1.9.cpanel                                     +  [2019-04-19 07:42:35 -0500] info [xml-api]   ea-php71-pear.noarch 0:1.10.7-1.1.9.cpanel                                     
-[2019-04-19 07:42:35 -0500] info [xml-api]   ea-php71-php-cli.x86_64 0:7.1.28-1.1.1.cpanel                                  +  [2019-04-19 07:42:35 -0500] info [xml-api]   ea-php71-php-cli.x86_64 0:7.1.28-1.1.1.cpanel                                  
-[2019-04-19 07:42:35 -0500] info [xml-api]   ea-php71-php-common.x86_64 0:7.1.28-1.1.1.cpanel                               +  [2019-04-19 07:42:35 -0500] info [xml-api]   ea-php71-php-common.x86_64 0:7.1.28-1.1.1.cpanel                               
-[2019-04-19 07:42:35 -0500] info [xml-api]   ea-php71-php-devel.x86_64 0:7.1.28-1.1.1.cpanel                                +  [2019-04-19 07:42:35 -0500] info [xml-api]   ea-php71-php-devel.x86_64 0:7.1.28-1.1.1.cpanel                                
-[2019-04-19 07:42:35 -0500] info [xml-api]   ea-php71-php-ftp.x86_64 0:7.1.28-1.1.1.cpanel                                  +  [2019-04-19 07:42:35 -0500] info [xml-api]   ea-php71-php-ftp.x86_64 0:7.1.28-1.1.1.cpanel                                  
-[2019-04-19 07:42:35 -0500] info [xml-api]   ea-php71-php-litespeed.x86_64 0:7.1.28-1.1.1.cpanel                            +  [2019-04-19 07:42:35 -0500] info [xml-api]   ea-php71-php-litespeed.x86_64 0:7.1.28-1.1.1.cpanel                            
-[2019-04-19 07:42:35 -0500] info [xml-api]   ea-php71-php-posix.x86_64 0:7.1.28-1.1.1.cpanel                                +  [2019-04-19 07:42:35 -0500] info [xml-api]   ea-php71-php-posix.x86_64 0:7.1.28-1.1.1.cpanel                                
-[2019-04-19 07:42:35 -0500] info [xml-api]   ea-php71-php-xml.x86_64 0:7.1.28-1.1.1.cpanel                                  +  [2019-04-19 07:42:35 -0500] info [xml-api]   ea-php71-php-xml.x86_64 0:7.1.28-1.1.1.cpanel                                  
-[2019-04-19 07:42:35 -0500] info [xml-api]   ea-php71-runtime.x86_64 0:7.1.28-1.1.1.cpanel                                  +  [2019-04-19 07:42:35 -0500] info [xml-api]   ea-php71-runtime.x86_64 0:7.1.28-1.1.1.cpanel                                  
-[2019-04-19 07:42:35 -0500] info [xml-api] Finished Transaction +  [2019-04-19 07:42:35 -0500] info [xml-api] Finished Transaction 
-[2019-04-19 07:42:35 -0500] info [xml-api] Leaving Shell+  [2019-04-19 07:42:35 -0500] info [xml-api] Leaving Shell
 </code> </code>
  
control-panels/cpanel-whm/how-to-use-easyapache4.1570738773.txt.gz · Last modified: 2019/10/10 15:19 by Karson N.