Timothy Kline

New Member
This past Friday, my dedicated server was upgraded to an SSD. A stock OS was installed on the SSD and then account restorations went next.

One of the shockers was that all dedicated IP addresses were reset back to the primary IP, breaking two of my largest clients' sites. Got that sorted out. Next crisis, please.

I worked my way through the other accounts, which all worked fine except for four Wordpress sites. They all reported the same error:

Error establishing a database connection

Normally, this means that the WP-CONFIG of an account has credentials different from those of the system.

And thus begins the mystery.

The credentials are all accurate when and as-entered.
But no connection to MySQL.

I decided to take one of the inactive accounts and wipe out the Wordpress and start anew.

Everything seemed fine during the installation process. At the end, Softaculous provided a link to both the landing and home page. When I clicked on either link, I would immediately flip to the connection error.

This was repeatable, and provided the same results with every attempt.

To rule out Softaculous perhaps playing a role in this, I went ahead and attempted a manual install. Again, I have made unreservedly certain that the credentials matched during this step. The manual install wouldn't even complete. I can get to the page where I provide the credentials, and after Submit it pops up the error in connecting.

Tech support has been unable to provide any solution as of this writing.

Did I mention that even when I flatly delete the CPanel account in WHM and then create it again, all of the above still takes place.

I'm hoping that through crowd-sourcing here, I can find a solution which I am confident will also resolve the similarly-impacted accounts on the host.

Thank you, in advance!

Timothy Kline
Hi Tim,

Had a similar experience not exactly as yours but kinda sorta similar after updating a VPS. Could not use the softaculous backup tool. Gave a wrong credentials error.

Here is the KH recommendation:

I had to edit the installation's details in order to get the backup for http://domain.com to complete successfully. To correct each installation and make the backups, first, to the cPanel page, Softaculous page, All Installations, then click Edit Details under Options. Next, you will find the "Database Host" and change its value to the following:

Then click "Save Installation Details" and proceed with making the backups as you normally would.

Maybe the could be a clue to your problems also.

Hope this helps a bit.
Thank you for your suggestion, Curdude!

I tried that, but no go.

Chase L. in Support might have found the issue after several other dead-ends.

my.cnf(MySQL configuration)
old-passwords = 1

He disabled it and in doing so restored access to the account I've been focusing on so that Wordpress now installs both through Softaculous and manually.

It looks like the change didn't help with the others that have the same issue that are already installed. Will continue to plug away on it.

Just by way of follow-up:

To resolve the remaining database connection issues, I used WHM to change the MySQL password for the impacted users to match the one listed in their respective wp-config file.

Thank you to Chase L., Freddie A., and Luke M. for putting up with my persistent clamoring on about this. It was a strange gremlin because, as Chase noted, it wasn't showing up in logs and by all rights the setting should have allowed the connection but wasn't for some inexplicable reason (as of this writing). It's no wonder it took as long as it did to finally nail down the bug.

--Timothy Kline