One SSL site showing on other domains

Discussion in 'Linux VPS/Dedicated - cPanel' started by hatimdisawala, Sep 17, 2016.

Tags:
  1. hatimdisawala

    hatimdisawala New Member

    Hi,

    I have multiple domains on a VPS and have bought SSL for one domain. When i open other domain with https:// it shows me first domain website. for e.g i have purchased SSL for this https://www.fesfna.org and when i open https://www.peacequarters.com with https:// it shows me https://www.fesfna.org site. This is happening with all other non-SSL websites on same VPS. Please let me know solution to this.

    Thanks.
     
  2. phpAddict

    phpAddict Active Member

    Are both of these websites on the same cpanel account? From first glance it appears that they're on the same account with some odd htaccess setting.
     
  3. hatimdisawala

    hatimdisawala New Member

    No, VPS account is same. CPanel are different for all.
     
  4. aussie7

    aussie7 Member

    This happened to me to, after I had bought a SSL cert and had support install it for me.

    Support said all was fine, so no idea what caused it sorry and things went back to normal after a few days

    On mine it was separate cpanel and same vps
     
  5. phpAddict

    phpAddict Active Member

    I just discovered my server does the same. When going to a site that has no valid SSL Cert, it redirects me to one of my sites that does has a valid Cert same as yours. Interesting. I'm going to look into it further later today.
     
  6. Dan

    Dan Moderator

    I looked at this briefly the other day and came across some posts on cPanel's forums saying that this was on account of SNI and that it was 'by design'. Why someone would think that this was a good design is beyond me.

    Further digging today reveals that cPanel's answer to this issue is their AutoSSL feature and, additionally, the Let's Encrypt plugin. Going this route you can get free SSL certs for each domain that does not already have one. I had read about AutoSSL and Let's Encrypt pre-release but have not enabled it yet. This is as good a time as any I suppose!
     
  7. phpAddict

    phpAddict Active Member

  8. Dan

    Dan Moderator

    AutoSSL and Let's Encrypt did the trick here.

    #1) Confirmed that it was working as stated by the OP
    #2) Followed these instructions for AutoSSL and the Let's Encrypt plugin (Note: you don't have to install the Let's Encrypt plugin, I just did)
    #3) Enabled Let's Encrypt as my AutoSSL provider (Accepting the Terms of Service and creating a new account with the provider)
    #4) Click the button Run AutoSSL for all users
    #5) Give it some time to run
    #6) Upon completion clicked the Logs tab in AutoSSL and saw that all applicable users had been assigned SSL certs
    #7) Went to Manage SSL Hosts and went down the list confirming that they all brought up their own site

    Now all my users have SSL for free fer nuthin! Cool beans!
     
    KH-JonathanKW and phpAddict like this.

Share This Page