register_globals and allow_url_fopen

imlek

New Member
Hello,

The reseller server have PhpSuExec enabled so I can not turn off some PHP value at .htaccess and must at php.ini

I never use php.ini before so would like to ask your advice to turn off the following value:
register_globals
allow_url_fopen

Thank you in advance.
 

LeMarque

Member
I just joined KH so someone please verify my response; it's been awhile since I did this.

But I recall you can turn suexec off in WHM (I believe in Tweak Settings?)

And the easiest way to edit php.ini is to ssh into your server, do a "locate" php.ini (think it may be in /etc) use a good ssh client, I use SecureCRT, make a backup of php.ini and then edit away!


HTH

Lance
 

drwhit73

Member
Not sure exactly how the reseller hosting works here but I would think that suexec could not be disabled on a single reseller hosting account. As far as the php.ini I am not exactly sure what directives to use to accomplish what you are wanting.
 

orici

New Member
same

I am having the same problem.
need register globals off, theres supposedly alot of people on Knownhost using joomla please whats the easy way?

this server doesnt allow .htaccess php_flag register_globals off
 

orici

New Member
solution

contacted support
they uploaded a php ini file with register globals turned off.

I have joomla installed so i moved the php.ini from public_html into my administrator folder and it works.

:)
 

Dallas

New Member
contacted support
they uploaded a php ini file with register globals turned off.

I have joomla installed so i moved the php.ini from public_html into my administrator folder and it works.

:)

I'm curious - how did they write it in the php.ini? Is it register_globals = Off, or something different?
 

LeMarque

Member
I just ssh'd into my server and did a "whereis" for php.ini. It returned a number of listings and am wondering if someone can tell me if this is THE php.ini file:

/usr/lib/php.ini
 

i.s.s.w

New Member
hi on ssh

php -i | grep php.ini

look php.ini


Configuration File (php.ini) Path => /usr/local/lib/php.ini

next

pico /usr/local/lib/php.ini

next
ctrl + w


----------------------------
I do not know many Arabs in the English language ;)
 
Top