InnoDB disabled for you? try this..

Discussion in 'Linux VPS/Dedicated - cPanel' started by Stephen Schmitt, May 1, 2013.

  1. Stephen Schmitt

    Stephen Schmitt New Member

    Hi folks,

    I'm new to knownhost and VPS hosting in general.. and am preparing to migrate my website over from another shared hosting provider.

    I thought I would post here an interesting dilemma and how I solved it because I bet it affects others here:

    After first logging in, I found that MySQL didn't support the InnoDB storage engine on my new vps server, which is a major problem as I need the transactional/acid support that it provides. After quite a bit of poking around and googling ( getting used to having root access!) I finally found the mysql errorlog files and the reason for the problem.

    In the log file was these lines:

    Code:
    130430 21:43:51 InnoDB: Using Linux native AIO
    130430 21:43:51  InnoDB: Warning: io_setup() failed with EAGAIN. Will make 5 attempts before giving up.
    InnoDB: Warning: io_setup() attempt 1 failed.
    InnoDB: Warning: io_setup() attempt 2 failed.
    InnoDB: Warning: io_setup() attempt 3 failed.
    InnoDB: Warning: io_setup() attempt 4 failed.
    InnoDB: Warning: io_setup() attempt 5 failed.
    130430 21:43:53  InnoDB: Error: io_setup() failed with EAGAIN after 5 attempts.
    InnoDB: You can disable Linux Native AIO by setting innodb_use_native_aio = 0 in my.cnf
    130430 21:43:53 InnoDB: Fatal error: cannot initialize AIO sub-system
    130430 21:43:53 [ERROR] Plugin 'InnoDB' init function returned error.
    130430 21:43:53 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
    


    Taking that advice and editing the etc/my.cnf file to add the innodb_use_native_aio = 0 line and and restarting the mysql service fixed the problem.

    Just thought I would share in case anyone else is having this problem! I'm sure there's a better solution than just disabling the native_aio, but the above got me up and running...
     
    Big Dan likes this.
  2. KH-Jonathan

    KH-Jonathan Director of Managed Services Staff Member

    Stephen,

    Thanks for the great post. I've only seen this in one instance, and I recall indeed resolving it by adding the code you mentioned to the my.cnf file.

    We've spoken with cPanel about this and they say it's just a bug with the new version of cPanel and they're supposed to be fixing it.
     
  3. KW802

    KW802 New Member

    Another on here where InnoDB was showing as disabled with no apparent way of fixing it except for adding "innodb_use_native_aio=0" to my /etc/my.cnf file & restarting the mysql service. :(

    Any thoughts on if there are any performance issues if we were to use InnoDB tables with that option turned off?
     
  4. KH-Jonathan

    KH-Jonathan Director of Managed Services Staff Member

    I did a ton of research on this particular case and wasn't ever able to locate anything leading me to believe that the "innodb_use_native_aio" hurts performance in any way.
     
  5. KW802

    KW802 New Member

    Thanks. :) From reading up on the issue it appears that having it turned will use simulated AIO versus hardware enabled AIO and since hardware support is new as of InnoDB 1.1 then it is no worse than before with having it turned off.

    As for why it was causing problems, at least on my VPS build it appears that AIO native may have been defaulted as true but libaio is not installed which it requires.
     

Share This Page