Help with Email errors

Discussion in 'Linux VPS/Dedicated - cPanel' started by pmcwebs, Mar 6, 2008.

  1. pmcwebs

    pmcwebs Member

    Hey all,

    I've got a client who is having trouble sending to one particular domain. He keeps getting the following error:

    Reporting-MTA: dns;
    Content-Type: text/plain

    Final-Recipient: rfc822;[email protected]
    Action: delayed
    Status: 4.0.0 (temporary failure)
    Remote-MTA: dns; []
    Diagnostic-Code: smtp; 4.1.0 - Unknown address error 450-'4.4.1 Sender domain not found in DNS' (delivery attempts: 6)
    Will-Retry-Until: 11 Mar 2008 17:45:25 +1030
    I've checked his email settings and can't see an issue. I've sent a test message to the account in question and also received the error. I've researched the error and have been unable to solve it. Is it likely I have an issue with my dns entries? My clients account and my own account are on the same VPS.

    Or perhaps the receiving domain has got problems with an overly aggressive mail filter?

  2. khiltd

    khiltd New Member

    What's the sender's domain?
  3. pmcwebs

    pmcwebs Member

    It is being sent from my client, although I get the same error when I send from my own domain.

    I don't normally run outgoing email via my server, I run it via my local ISP, I'm wondering if the error is because the sending mail server doesn't match the senders domain. ie: We are both sending via rather than for example
  4. khiltd

    khiltd New Member

    The error you were given would seem to indicate that they weren't able to resolve the sender's domain at all, but I suppose it could be related to the mismatch. Switching to your own SMTP may or may not help anything since it's advertising a different name as well:

    # telnet 25
    Connected to
    Escape character is '^]'. ESMTP Exim 4.68 #1 Fri, 07 Mar 2008 10:09:17 +1100
    220-We do not authorize the use of this system to transport unsolicited,
    220 and/or bulk e-mail.
    250 Hello []

    Assuming this isn't a newly created or modified DNS record which hasn't had time to propagate yet, I'd try making an SPF record first, and if that doesn't work then change the MX record to reflect the actual hostname i.e. "". If none of that helps, you'll probably have to talk to your ISP since they seem to be the ones complaining.
  5. pmcwebs

    pmcwebs Member

    No worries, thanks for giving me somewhere to start.


Share This Page