Anyone running Movable Type 4 on their Knownhost account?

Xiety

New Member
I am just wondering if anyone installed & runs MT4 on their Knownhost account. I have been trying in the past 2-3 days with no solution. Just trying to find out if its a server thing? Thanks.
 

KH-Paul

CTO
Staff member
Xiety,

I do recall at least couple customers who use MT. What kind of errors are you seeing while trying to run it?

What kind of service type do you have with us? I'll move the thread to the appropriate forum.
 

Xiety

New Member
Hi P,

I have reseller hosting and for the account in question I have CGI enabled.

Maybe you can help me if I posted MT's requirements?

Movable Type requires the following applications:

  • Perl 5.6.1 or greater;
  • A web server like Apache, or Windows IIS;
  • Access to a database like MySQL, SQLite or Postgres;
  • The following Perl modules:
I assume all these are available on Knownhost as they mention on MT forums that most hosting providers have them?

Anyways, here're the instructions for installing Movable Type (bolded are what I did):

  1. Use a Web browser to connect to the Movable Type Download page and follow instructions there to download the Unix/Linux/Mac OS X (.tar.gz) release file to your personal computer. (done)
  2. Extract the Movable Type files from the release file into a new folder on your local computer. You will need a program that can uncompress and extracts tar files. If you don't have such a program, you can learn how to get one on the gzip home page, http://www.gzip.org. (done)
  3. Start your FTP program and connect to your Web server using your server login name and password. (done)
  4. Copy the mt-static directory from your local computer to the Web root directory on the Web server. (done)
  5. Open the cgi-bin directory on your Web server. Make a new directory within it named mt. Copy all of the other Movable Type installation folders and files to the mt directory. (i assume this is the cgi-bin directory under public_html, done)
  6. Make sure all the Movable Type cgi files (files ending with .cgi) in the mt directory on the Web server have execute permission. You should be able to select these files and check their properties with your FTP program. (done)
  7. Make sure the support directory found within your mt-static directory is writable by your web server. (done)
  8. Start a Web browser and run the installation wizard by connecting to the following Web address: http://domainname/cgi-bin/mt/mt.cgi where "domainname" is the domain name for your blog. and this is where it gives me the error posted below.
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, webmaster@laikturkiye.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
 

KH-Paul

CTO
Staff member
Xiety,

Thread moved to Reseller hosting forum.

The problem is related to wrong permissions on the public_html/cgi-bin/mt/mt.cgi script:

[2008-05-27 15:09:17]: file has no execute permission: (/home/USER/public_html/cgi-bin/mt/mt.cgi)

I changed permissions to 755 and was able to access http://domainname/cgi-bin/mt/mt.cgi however now it shows a different error about missing /mt-config.cgi file. Sounds like script paths are not defined correctly somewhere in this application's configuration.
 

Xiety

New Member
I think it has something to do with where the CGI directory is located.

I read in another thread that cgi-bin should be outside the public_html folder. I think that may be the reason. I asked a few friends to check their server and they confirmed that. Is it normal that my cgi-bin is in my public_html directory?
 

Xiety

New Member
Xiety,

On cPanel servers cgi-bin directory is located inside the public_html directory.
Thanks for your help Paul. I gotta ask though, if that is the case with accounts with cpanel, does that mean MT users at KH have a custom solition or there's some other method where I can get rid of cpanel and have cgi-bin where MT wants it to be? Cheers.
 

KH-Paul

CTO
Staff member
Xiety,

Physical location of the cgi-bin directory doesn't really matter in the real world. I'm pretty sure this is a result of some sort of MT mis-configuration.
 

Xiety

New Member
Hate to make it sound like I am trying to blame it on anyone, but tried MT on a friend's site hosted elsewhere (BH) and got it working ... :-/
 

KH-Paul

CTO
Staff member
Xiety,

I'm not sure if this will help but have you tried to complete the step #6 from the instructions you've pasted in the 3rd post in this thread?

Code:
Make sure all the Movable Type cgi files (files ending with .cgi) in the mt directory on the Web server have execute permission. You should be able to select these files and check their properties with your FTP program. (done)
As I can see the only cgi file with executable permissions in your public-html/cgi-bin/mt directory is the one that was changed as per post #4.

Regards,
Paul
 

Xiety

New Member
Thanks for reminding me Paul.

Yeah I had done that earlier. It's just that I forgot to re-edit permissions when I tried a fresh start from step 1 after numerous failures :)

I posted a thread on MT forums... maybe someone can help over there... I'll post here if I come across a solution.
 
Top