www part won't work?

Discussion in 'Linux VPS/Dedicated - cPanel' started by cjl, Feb 13, 2008.

  1. cjl

    cjl New Member

    I'm admittedly very lame when it comes to all this stuff so please forgive me if this is a dumb question.

    Yesterday the great support staff here recompiled Apache for me. Everything is working great except with one of my domains. It's accessible only through blahblah.com and not www.blahblah.com. Can someone tell me what I need to do to fix this? Thanks!
     
  2. mylinear

    mylinear Member

    I suggest you submit a ticket and support will fix it for you.
     
  3. roosevelt

    roosevelt New Member

    I believe the error is in DNS Zone. Try this:

    1) Login to WHM

    2) Go to DNS Functions -> Edit DNS Zone

    3) Choose the domain you are having trouble with and click Edit.

    4) Check and see if there's an entry which looks like below:

    Domain: www
    TTL: 14400
    Record Type: CNAME DOMAIN.COM

    Where DOMAIN.COM is blahblah.com
     
  4. cjl

    cjl New Member

    Thanks for the suggestion. There is an entry like that for the problem domain. I guess I'll have to contact support again although I wanted to give them a break. ;)
     
  5. laguna

    laguna New Member

    related subdomain dns zone problem

    Hello,

    I am having a related problem, see my post:

    http://forums.knownhost.com/showthread.php?t=1346

    I notice the my DNS zone has a record for the subdomain that works but does not have a record for the subdomain that doesn't work. I created both with cpanel so I'm not sure what the issue is.

    So I need to add an 'A' record for the subdomain? And to do that I just type in the subdomain name and ip address, leaving it set for 14400 and A, and then click add?

    I also see the subdomain that works has two records. One is subdomain and the other is www.subdomain. Do I create both records very every subdomain I want?

    Also any ideas why cpanel is not automatically doing this?

    Thanks
     

Share This Page