Wordpress questions about WP-Admin/admin.php

e-nes

New Member
Hello All,
I have not opened a ticket yet, wanted to ask you guys first about this and see if anyone was able to duplicate this issue.

Having issues with a plugin giving out 404 errors, that appear to be related to admin.php.

Plugin in question: Pods - https://wordpress.org/plugins/pods/
Issue: Unable to edit, delete or change settings. All those links involve the admin.php page and usaully occur when one or more amper stamp (&) is included (sitename.xyz/wp-admin/admin.php?page=pods&action=edit&id=58)

Troubleshooting and duplication:
Tired this on several existing sites, disabled all other plugins, different theme, stock theme
wp_debug, check logs, checked memory limit
Even tried it on a brand new, fresh site that was just added.

Finally, I noticed that the wp-admin/admin.php is blank. I still access the admin area, the index for admin shows up just fine but admin.php does not display.

So, I am hoping you guys could help me check this before I open a ticket.
Should the wp-admin/admin.php page display? (Searching resulted in issues with accessing wp-admin/dashboard, not with accessing the admin.php page.)
Would someone be willing to test the pods plugin and see if they have issues with editing or deleting. (Searching provided no results.)

Thanks in advance for your assistance!
 

KH-DanielP

KH-COO
Staff member
@e-nes

Login to WHM on your server, travel to the PHP Configuration Editor. Check for "disabled_functions" , save a copy of the list but try removing things like ini_set or exec to see if that allows the page to fully load.

Would be one of the first things I check for. Ideally you wouldn't need exec functions out of php but not all php developers program with a sense of safety :)
 

e-nes

New Member
Hello Daniel,
Thanks for the quick reply.

I had no success with removing all options from disable_functions.
Appreciate you taking time to help. Open to trying to anything (at least once).
Please let me know if you or anyone else has any suggestions/ideas.

Thanks again!

Details:
Home »Service Configuration »PHP Configuration Editor
Current "disable_functions" list - " show_source, system, passthru, exec, popen, proc_open, allow_url_fopen "

I tired individually removing "exec" , "allow_url_fopen" and then I tired with clearing the whole line.
Then restarting http server (apache) - not sure if that is a good or bad idea
And attempting again to access the pages (after force-reloading).
 

KH-DanielP

KH-COO
Staff member
You mentioned in your first post that you checked the logs. Did you look in your home directory for any error_log files?

PHP will often dump it's errors to these files, sometimes in the main public_html, other times in the folder of the php script generating the error. So this could be the admin folder, or the plugin folder its self. Anything in those files might lend a clue to why it's not processing.

As far as the admin.php being blank, this is by design, went ahead and verified it on one of our test installs so don't let that lead you too far astray in the troubleshooting.
 

e-nes

New Member
New test site has no error logs under public_html or the wp-admin folder.
The other site (first one I had issues with) had errors in the wp-admin folder but those were from me testing different things in relation to a blank admin.php.

So, this issue is present in my new test site on the same vps. New test site is clean with default themes and only this plugin installed.
Any chance you guys could verify this and see if you could duplicate on your test install if the pods plugin can edit, delete a new created pod?

I have had a similiar issue (where pages pulling from admin.php? error out with 404) on other sites and other plugin pages, but always thought it was related to conflicting plugins or wordpress security plugins.
Since it is happening on a test site, I wonder if it is related to my vps setup.

Again, if there is any chance you guys could test the pods plugin on your test site and verify if you have the issue?
Then we can determine if this is a plugin issue or a VPS settings matter and if needed open a ticket.


Thank you again for all your help, really appreciate it!
 

phpAddict

Active Member
Hello @e-nes not sure if you're still having this issue, but...

Did you install this plugin through your wp backend's plugin page (/wp-admin/plugin-install.php), or did you manually install it by downloading and uploading the zip file?

Could you give us a sample of some of the URLs that are giving you a 404 page? (You can strip out your domain name if you like)
 

e-nes

New Member
@phpAddict and @Dan Thanks for the reply.
/wp-admin/admin.php?page=pods&action=edit&id=4
From a novice standpoint, seems silly but most pages that have a & after the ?page= would error out with 404.
This happens with both the pods plug-in and mailpoet.

The plugin was added via the the back-end. I will to try to upload later tonight.
I even went through permissions, the functions.php, wp-config.php, .htaccess, check every folder for errors and even made a bloody test site for this.
Any and all help is appreciated!
 

e-nes

New Member
@phpAddict
Thanks for the reply and the suggestion.
I tired what you suggested, and no issues.
Even tried it with a newly created test.php file

mydomain.com/test.php?test1=1&test2=2
mydomain.com?test1=1&test2=2
Both worked no issues.

------------------------------------------------------------------------------------------------------------------------------------------------------
Should we start the troubleshooting all over? Originally, I thought this was an issue of one site but it happens on new test accounts. I don't know where to go next. Would like to get this solved and willing to try anything.

Thank you again to all (@phpAddict, @KH-DanielP and @Dan) for your feedback and suggestions.
Very eager to solve this or have some closure to the cause.

Thanks again!
 
Top