why the defaults email ports are opened when no mail server installed

Status
Not open for further replies.

class101

New Member
hello,

I have installed Postfix and have troubles to have it working simply because there is default ports opened 25 110 995 etc on my machine when connected it timeouts without no mail server running on the machine ... So then when I start my Postfix mail server, the postfix ports are not recognized and instead it timeouts due do the default opened ports, I have checked if it was from my connection but no because intodns and dnsstuff aren't detecting the mail server also, it is just working locally from the ssh, if I type telnet ip 25/110/etc, working fine.

Any idea what is causing this? have only apache mysql proftp php installed and checed in webmin the Internet service ports, nothing is enabled so no ports overwritte from there.
 

class101

New Member
well I will submit a ticket and if nothing moves tommorow I will search for another VPS hosting because that sound like a <snipped> configuration I can't get my hand on and that's not acceptable for a mail server
 

KH-Paul

CTO
Staff member
class101,

If nothing listens on port 25, then this means that mail server isn't running. How postfix was installed? What kind of errors are you seeing while you're trying to start it? Is there anything in logs?

Please edit post #4 and adjust your language. We'll appreciate if you can keep yourself professional, especially in public places.

Regards,
Paul
 

class101

New Member
The problem is not with POSTFIX , why the support is installing POSTFIX now ??? I recall I can't setup ANY mail server because there is DEFAULT PORTS 25/110 THAT ARE OPENED AND BLOCKING STANDARD MAIL PORTS.

FROM INTERNET
[R] Connecting to 65.99.213.138 -> IP=65.99.213.138 PORT=25
[R] Connected to 65.99.213.138
[R] Connection failed (Connection lost)

[R] Connecting to 65.99.213.138 -> IP=65.99.213.138 PORT=110
[R] Connected to 65.99.213.138
[R] Connection failed (Connection lost)

FROM LOCALHOST (that's normal no erros here)
[R] Connecting to 65.99.213.138 -> IP=65.99.213.138 PORT=25
[R] Connection Refused
[R] Connecting to 65.99.213.138 -> IP=65.99.213.138 PORT=110
[R] Connection Refused



now root pass as changed, believe me KnownHost, if you do not fixe this you will listen about my review at webhostingtalk you can be sure.
 

class101

New Member
I never told you to change my root pass, you know people they tell you the root passwd for investigation support, then they arg hey you dont have postfix installed we will install it ( the funnier is that it is already installed but not running..) and now they changed the root passwd, unbelievable.

Code:
[FONT=Verdana, Arial, Helvetica][SIZE=2] We could not see Postfix installed in the VPS and no service is listening on port 25.
We are now installing Postfix and will get back to you soon with details.

Thanks,
Mike
KnownHost Support 
[/SIZE][/FONT]
[FONT=Verdana, Arial, Helvetica]

So how come the ports are OPEN if nothing is listening on this ports ???

[/FONT] FROM INTERNET
[R] Connecting to 65.99.213.138 -> IP=65.99.213.138 PORT=25
[R] Connected to 65.99.213.138
[R] Connection failed (Connection lost)

[R] Connecting to 65.99.213.138 -> IP=65.99.213.138 PORT=110
[R] Connected to 65.99.213.138
[R] Connection failed (Connection lost)

You can see I detect them OPEN and it reject the connection 10sec after ... DNSSTUFF and INTODNS also are detecting these timeouts ports. So RUNNING ANY MAIL SERVER BEHIND THESE PORTS WILL LAND IN A TIMEOUT CONNECTION THATS WHAT IM TRYING TO SAY SINCE YESTERDAY , I DO NOT NEED A HOW TO POSTFIX INSTALL THANKS!


Port 25/110 etc must be closed at all to me by default , but why it opens without nothing listening on the root box ? Because you have a misconfiguration that's simple !
 

class101

New Member
The prob is that the default OPEN state of some ports (in this case 25/110 etc) without any running services behind them is overwritting then any service I'm running under... I hope you are not searching at fixing Postfix but rather your customer Firewall or something like. Because if I would like to run apache under the Port 25 or 110 for example , that would be the same , unacessible because of theses ports in an opening state and rejecting the connection then for a short period.

I know I have a crap english but is this so hard to understand I'm not telling Postfix Tut :/

I know a workaround that would be to just change my default postfix ports to something other than 25/110 but then my mailserver won't be accessible by most people but I'm sure it would work because other ports are responding a REFUSED state wich is normal, but why only the common email ports are open by default via the internet, here is the ALL the problem, because I recall, locally, Postfix is running fine on theses ports because locally theses ports are in a REFUSED state without any running service behind, so the glitch can come from only something between me/intodns/dnsstuff and the server, like a firewall, router, well I don't know how you are setting up your business, at least I'm sure I cannot Firewall one port, the Virtuozzo port 4643, wich is for my security I guess, but my problem can come from the product doing this special protection for example.
 

class101

New Member
I need some member's test please try connecting(with your ISP):

65.99.213.138:25
65.99.213.138:110

and please gimme the results open, refused etc, thanks.
 

class101

New Member
I would lie to excuse me for the confusion , that was coming from my Kaspersky Proactive Protection that flagged the VPS system as an attacker , I dunno when , but then it acted on the whole system to put it in a virtual environment when I was ttrying to connect mail port of this IP, so not a KnownHost Problem, I forgot Kaspersky scans these ports, thanks a lot to the http://ping.eu/port_chk/ port checking tool. Issue Fixed.
 

khiltd

New Member
"Refused" and "open" are two entirely different things, neither of which is worth getting this worked up over.
 

class101

New Member
Yep I was confused but finally found out that was Kaspersky monitoring those outgoing ports by default on my machinesn hey khiltd what email server are yu using ?
 

khiltd

New Member
I'm using UltraMegaMail Pro with Automagic Blame Displacementâ„¢ technology and IdleThreatMaker 7 HyperAggression transference. It's the only solution I've found that allows me to pour maple syrup down my router's vents and then yell at other people when my email stops working.
 

ppc

Moderator
so not a KnownHost Problem, I forgot Kaspersky scans these ports, thanks a lot to the http://ping.eu/port_chk/ port checking tool. Issue Fixed.
It's the only solution I've found that allows me to pour maple syrup down my router's vents and then yell at other people when my email stops working.
And with that we're going to close this thread. ;)

I'm glad the issue was resolved. Class101, we're all here to help you and if you give knownhost the chance they really have a top notch support team like no other.

Regards,
 
Status
Not open for further replies.
Top