Users cannot access Site, but I can?

Discussion in 'Linux VPS/Dedicated - General' started by mofolo, Jun 22, 2011.

  1. mofolo

    mofolo New Member

    Hello,

    Recently I've been getting quite a bit of users emailing me about my websites poor performance.

    They say they constantly cannot access the website (Getting timeouts) and slow responses when the connection is initiated.

    Every time I access the website from my laptop on my home network, I get no problems at all, and connection is zippy.

    I've used the same laptop to access the website via other networks (such as my Universities); and (sometimes) the connection fails and/or is really slow to load. But then again, the University's wifi network is quite poor in the speed department.

    What could be the reason why this is happening?
    Apache? PHP/MySql bottle necking?

    The KH crew are reporting that the site works fine on their end too. It's phenomenal how I cannot pin point where the problem is!
     
  2. Dan

    Dan Moderator

    Hi mofolo,

    Have you tried using something like Alertra that will access your site from different locations? That might be something to try.

    If you would like to PM me your site and I give it a try from my end as well.

    If it were a Apache or MySQL you would see it on your end as well so I am inclined to think that is not the problem.
     
  3. mofolo

    mofolo New Member

    I'm using Pingdom at the moment to monitor my website.

    It's running at 68% Uptime :(

    Here is the overview provided by Pingdom:

    Uptime
    68.18%

    Downtime
    3h 19m 51s

    The average downtime length is 1m 51s

    Number of downtimes
    108
    The longest downtime was 8m on 06/23/2011 7:45:49AM and the shortest was 55s on 06/23/2011 8:15:54AM


    As you can see, the average downtime is no longer than 2 minutes, but it happens 108 times in a 24 hour period. The website is: www.myrepospace.com

    Edit:
    Also, in some of Pingdom's downtime analysis reports, the HTTP status from the server returns this:
    HTTP CRITICAL - Unable to open TCP socket
     
  4. kingtas

    kingtas New Member

    It just timed out for me a couple of times and then displayed. Perhaps you are running out of memory?
     
  5. mofolo

    mofolo New Member

    Maybe..

    Here's my free -m:

    total used free shared buffers cached
    Mem: 2048 333 1714 0 0 0
    -/+ buffers/cache: 333 1714
    Swap: 0 0 0

    Here is my -top:

    up 49 days, 12:25, 1 user, load average: 1.23, 0.82, 0.77
    Tasks: 91 total, 2 running, 80 sleeping, 0 stopped, 9 zombie
    Cpu(s): 3.0%us, 1.4%sy, 0.0%ni, 95.7%id, 0.0%wa, 0.0%hi, 0.0%si, 0.0%st
    Mem: 2097152k total, 319008k used, 1778144k free, 0k buffers
    Swap: 0k total, 0k used, 0k free, 0k cached
     
  6. mofolo

    mofolo New Member

    I'm currently at university, and I cannot make a connection to the server via ping and cannot achieve a tracert successfully to the server. Any Ideas? :confused:
     
  7. Sirozha

    Sirozha New Member

    icmp/udp packets being dropped at the university? Where does the traceroute choke?

    BTW the "'HTTP CRITICAL - Unable to open TCP socket" message means that the problem was on Pingdom's side. They wasn't able to open an http connection to your site due to resources shortage. Meaning that their reports/monitoring might be useless.
     
  8. mofolo

    mofolo New Member

    It gets to a host titled

    4. wod-border....
    and then times out from then on.

    So im guessing the router can't successfully route a path to my server hosts.

    As I said before however, sometimes the server is accessable, and the website runs fine for 1-2 pages, but then begins to slow down.

    Is it possible that this is a DNS issue?

    Also: I get 110 Errors when trying to access the website.
     
  9. mofolo

    mofolo New Member

    OK, Scratch that..

    When I ping/tracert another server like Google.com, I get the same problem. Timeouts!
    It must be the gateway router at the univeristy.

    But that doesn't explain why I CAN access google with quick speed/faultless connect, but not my own server.
     
  10. Aussie_Boy

    Aussie_Boy Member

    I'm getting reports of my forum members having slow access over the last hour or so. When I access some topics on my forum, sometimes it sits for a few seconds and doesn't load, but if I refresh the browser or click the link again, it usually loads quick. Server load appears ok, tracert appears ok. Disk I/O issue maybe? I'm on vz34-ca
     
  11. mofolo

    mofolo New Member

    Im on vz101-tx

    I have no idea with mine.
     
  12. Dan

    Dan Moderator

    mofolo,

    Obviously it's not a memory issue but the CPU load is a bit high. If it's spiking that could very well cause timeouts.

    I ran a traceroute from here and it went through just fine. Ran Alertra on it a few times and things were fine there as well. But just browsing the site it ran about 50/50 for timeouts on page loads.

    Has the site grown a lot recently? Have you added new software or expanded recently?
     
  13. mofolo

    mofolo New Member

    No, No new Software has been added.

    Just running PHP/mySQL and using some simple linux system functions like "ar" and "zip"

    I do get quite a lot of downloads/uploads per day though.

    I don't think it's a CPU spike - I've been watching my "top" and the max it has gotten to was around 3.5, which I believe is pretty normal for a server under load?
     
  14. Dan

    Dan Moderator

    mofolo,

    If my VPS reaches 3.5 it is pretty much completely unresponsive. I am pretty sure that is what is causing your problems. Normal on my VPS is in the low decimal points but mine does not see anywhere near the load your does I am sure.
     
  15. mofolo

    mofolo New Member

    Oh Really?

    I was under the impression that anything under 5 was good.

    Well there we go, that must be the problem.

    I've been working all day trying to optimize some of my Scripts. Could you please test the website on your end and load a couple of pages.

    On my end the web server is always super fast, so I can't really test my optimizations at home..

    Oh, and I've been sitting on my top for a bit. Averaging 0.73 now. How's that rank?
     
  16. kingtas

    kingtas New Member

    Top is showing 95.7% idle.

    Cpu(s): 3.0%us, 1.4%sy, 0.0%ni, 95.7%id, 0.0%wa, 0.0%hi, 0.0%si, 0.0%st

    Have you submitted an official support ticket?
     
  17. mofolo

    mofolo New Member

    I completely missed that. I'll submit one now.
     
  18. mofolo

    mofolo New Member

    Support Tweaked my Apache. It's running a bit better now.

    I noticed this however, when running the command # ps aux

    nobody 20413 0.1 1.4 37456 30684 ? S 19:41 0:00 /usr/local/apac
    nobody 20431 0.1 0.2 11644 4828 ? S 19:41 0:00 /usr/local/apac
    nobody 20433 0.1 0.2 11644 4844 ? S 19:41 0:00 /usr/local/apac
    nobody 21545 0.1 0.2 11644 4824 ? S 19:41 0:00 /usr/local/apac
    nobody 21664 0.0 0.2 11644 4788 ? S 19:41 0:00 /usr/local/apac
    nobody 21687 0.0 0.5 17892 11064 ? S 19:41 0:00 /usr/local/apac
    nobody 22145 0.1 0.2 11644 4820 ? S 19:41 0:00 /usr/local/apac
    nobody 22211 0.1 0.2 11644 4812 ? S 19:42 0:00 /usr/local/apac
    nobody 22225 0.1 0.2 12048 5180 ? S 19:42 0:00 /usr/local/apac
    nobody 22342 0.1 0.2 11644 4816 ? S 19:42 0:00 /usr/local/apac
    nobody 22376 0.1 0.2 11644 4816 ? S 19:42 0:00 /usr/local/apac
    nobody 22399 0.1 0.2 11644 4800 ? S 19:42 0:00 /usr/local/apac
    nobody 22406 0.1 0.2 11644 4816 ? S 19:42 0:00 /usr/local/apac

    Lots of sleeping Apache processes just taking up CPU.

    Is this normal?
     
  19. mofolo

    mofolo New Member

    Found the Problem.

    The Firewall software: CSF was blocking many incoming connections.
    To fix it, I had to Turn SYSFLOOD protection off, which can be done in the csf.conf file.

    Thanks for the help guys.
     
  20. kingtas

    kingtas New Member

    That's much better. Nice find. Do you still have hair? :D
     

Share This Page