/~UserHome In Url

Discussion in 'Linux VPS/Dedicated - cPanel' started by Jan Wojtasinski, Feb 16, 2015.

  1. Jan Wojtasinski

    Jan Wojtasinski New Member

    After updating a few domains on my server to utilize dedicated IP's with SSL i have noticed a weird issue in WebMaster Tools. Google is indexing 2 copies of my site, the normal HTTPS url as well as the url with the users home directory. For example:

    Website Home:
    https://www.test.com/index.php

    Also website home:
    https://www.test.com/~UserHome/index.php

    Is there a convenient way to disable this in CPanel?

    Thanks!
     
  2. KH-Jonathan

    KH-Jonathan Director of Managed Services Staff Member

    Yep, you have two options. The first is swap your PHP handler to DSO and enable mod_ruid2 - which if you're using suPHP is recommended for speed anyway.

    Second option requires no such change. Security Center >> Apache mod_userdir Tweak in WHM and disable it.
     
  3. Jan Wojtasinski

    Jan Wojtasinski New Member

    Jonathan -

    Thanks! I am opting for the userdir tweak for now.

    Any insight on if switching from suPHP to DSO will cause issues with any of my Joomla or Wordpress installs and related scripts? I am currently running 2 domains with 3 dedicated IP's from this VPS. Also -- suPHP is rumored to be more secure in multi user environments in comparison to DSO. However, it sounds like the speed improvements are worth it?

    Jan
     

Share This Page