upcp failing

Discussion in 'Linux VPS/Dedicated - General' started by turbo2ltr, Jun 3, 2011.

  1. turbo2ltr

    turbo2ltr Member

    On Jun 1st my server tried to update to 11.30. I received an enormous email with the log in it. Here is the tail end of it.

    Code:
    [20110601.004632]      [8111] Done.
    [20110601.004633]   ==> Starting cPanel....
    [20110601.004633]    - Processing command `/usr/local/cpanel/etc/init/startup`
    [20110601.004633]      [9376] Waiting for cpaneld to shutdown ... ...Done
    [20110601.004633]      [9376] Waiting for webmaild to shutdown ... ...Done
    [20110601.004633]      [9376] Waiting for cphulkd.pl to shutdown ... ...Done
    [20110601.004633]      [9376] Waiting for cPhulkd to shutdown ... ...Done
    [20110601.004633]      [9376] Waiting for cphulkd to shutdown ... ...Done
    [20110601.004634]      [9376] [Wed Jun  1 00:46:33 2011] Current process '30251' stopped
    [20110601.004634]      [9376] Waiting for cpdavd to shutdown ... ...Done
    [20110601.004634]      [9376] Waiting for cpdavd-ssl to shutdown ... ...Done
    [20110601.004634]      [9376] Waiting for cpdavd-ssl to shutdown ... ...Done
    [20110601.004634]      [9376] Waiting for cpldapd to shutdown ... ...Done
    [20110601.004634]      [9376] Waiting for cppop to shutdown ... ...Done
    [20110601.004634]      [9376] Waiting for cppop-ssl to shutdown ... ...Done
    [20110601.004634]      [9376] Waiting for cpanellogd to shutdown ... ...Done
    [20110601.004634]      [9376] Waiting for entropychat to shutdown ... ...Done
    [20110601.004634]      [9376] Waiting for eximstats to shutdown ... ...Done
    [20110601.004634]      [9376] Waiting for melange to shutdown ... ...Done
    [20110601.004634]      [9376] Waiting for startmelange to shutdown ... ...Done
    [20110601.004634]      [9376] Shutting down Mailman's master qrunner
    [20110601.004635]      [9376] mailmanctl: no process killed
    [20110601.004635]      [9376] Waiting for eximstats to shutdown ... ...Done
    [20110601.004636]      [9376] Waiting for cpbandwd to shutdown ... ...Done
    [20110601.004637]      [9376] [2011-06-01 00:46:37 -0700] [main] Current process '30218' stopped
    [20110601.004637]      [9376] Waiting for tailwatchd to shutdown ... ...Done
    [20110601.004637]      [9376] Graceful shutdown of cPanel TaskQueue Daemon requested. complete
    [20110601.004637]      [9376] Waiting for cpsrvd to shutdown ... ...Done
    [20110601.004637]      [9376] Waiting for cpsrvd-ssl to shutdown ... ...Done
    [20110601.004637]      [9376] Waiting for whostmgrd to shutdown ... ...Done
    [20110601.004637]      [9376] Waiting for cppop to shutdown ... ...Done
    [20110601.004637]      [9376] Waiting for cppop-ssl to shutdown ... ...Done
    [20110601.004637]      [9376] ==> cPanel TaskQueue Processing Daemon version 1.0
    [20110601.004637]      [9376] [Wed Jun  1 00:46:37 2011] Starting /usr/local/cpanel/libexec/tailwatch/tailwatchd daemon
    [20110601.004637]      [9376] Log is at /usr/local/cpanel/logs/tailwatchd_log
    [20110601.004637]      [9376] Clearing main log /usr/local/cpanel/logs/cphulkd.log
    [20110601.004637]      [9376] ==> cPanel Log Daemon version 25.0
    [20110601.004637]    - Processing command `/usr/local/cpanel/whostmgr/bin/whostmgr2 --updateaddons`
    [20110601.004638]      [9526] Updating addon type:modules addon:cronconfig version:0.4.1.......Done
    [20110601.004638]      [9526] Updating addon type:modules addon:spamdconf version:0.5.......Done
    [20110601.004638]      [9526] Locale database build scheduled.
    [20110601.004638]   ==> Post Install Complete
    [20110601.004638]    - Processing command `/usr/local/cpanel/cpkeyclt`
    [20110601.004638]      [9536] Updating cPanel license...Done. Update succeeded.
    [20110601.004638]      [9536] Building global cache for cpanel...Done
    => Log closed Wed Jun  1 00:46:38 2011
    ----------------------------------------------------------------------------------------------------
    => Log opened from cPanel Update (upcp) - Slave at Wed Jun  1 00:46:38 2011
    [20110601.004638]   Post-sync cleanup completed successfully
    [20110601.004638]
    [20110601.004638]       cPanel update completed
    [20110601.004638]   A log of this update is available at /var/cpanel/updatelogs/update.1306914002.log
    [20110601.004638]
    [20110601.004638] Completed all updates
    => Log closed Wed Jun  1 00:46:38 2011
    Ever since then, whenever upcp runs, this is the only data it generates:

    Code:
    [20110602.004002]   Detected cron=1 (cron mode set from command line)
    [20110602.004002]   Killing former upcp process "1205", starting new..
    Notification => [email protected] via EMAIL [level => 1]
    [20110602.004002]   Sending kill signal to process group for 1205
    I also get an email:
    Code:
    /usr/local/cpanel/scripts/upcp was detected to be running as pid '30126'. Because it has been running for longer than 6 hours, the process will be killed and a new upcp will be run in it's place.

    Any ideas on how to fix this?
     
  2. Dan

    Dan Moderator

    Hi turbo2ltr,

    We could try digging through the full update log to see if we can determine what failed and fixing it but your best bet is probably going to be shooting a ticket in to support and having them take a look :)
     

Share This Page