SSH start speed

Discussion in 'Linux VPS/Dedicated - General' started by ejellard, Mar 21, 2008.

  1. ejellard

    ejellard New Member

    Hi,

    I've just signed up for a VPS, L-plan and everything is going very well, except it takes at least ten seconds for me to SSH from my home computer to it - I don't have this issue with SSH'ing into other places - is this a normal duration for knownhost VPSes, or is there something I could do to improve the speed?

    Also, I'm absolutely amazed by the sales and tech support speed, even on Good Friday, so will be moving everything over here once I've set up the server properly!

    Cheers,
    Ed
     
  2. Bryan

    Bryan Very Happy KH VPS User

    Hey Ed, and welcome to Knownhost!

    I can't speak for all the VPSs here, but on mine in the new CA datacenter (and the one I had in the old one for that matter), everything SSH happened immediately, from the prompt coming up to logging in. Ten seconds seems ridiculously long.
     
  3. ejellard

    ejellard New Member

    Hi,

    Thanks for the welcome! I've done a little more digging, and from my soon to be ex-hosting company, I can SSH in almost immediately, so it's got to be something to do with my ISP I guess - possibly not liking port 2200 or something...

    Time to play with the config files!

    Cheers,
    Ed
     
  4. khiltd

    khiltd New Member

    I'm not entirely sure ten seconds is worth complaining about.
     
  5. ejellard

    ejellard New Member

    Sorry, I wasn't meaning to "complain", just wondering if there's a way to speed it up. I changed the port to the 22 and made no difference, so I think it's just an ISP thing and not a lot I can do about that!
     
  6. drwhit73

    drwhit73 Member

    Welcome to Knownhost.
     
  7. ppc

    ppc Moderator

    Probably is an ISP "issue", I think almost all of us can say that our VPS's fly here at KnownHost.

    Regards,
     
  8. ejellard

    ejellard New Member

    drwhit73, thanks for the welcome!

    ppc, I changed the sshd_config file to one from my local fedora install, and used "UseDNS no" and it is now flying - I think as I don't have a static IP address and no reverse dns entries on my home internet connection, there were some strange problems.

    On a side note - I've asked knownhost to add a reverse dns entry for my primary domain (which they did in minutes, thank you!) - is it ok to have reverse dns entries for my other domains, or can one IP address only point to one domain? I'm not used to reverse dns (and after spending hours trying to get it to work myself, I read on the forum that it has to be done by knownhost - no idea why, but hey!), so sorry if that's a stupid question!

    Thanks,
    Ed
     
  9. Dan

    Dan Moderator

    Hello Ejellard,

    On my VPS UseDNS is commented out so I can't say whether that would cause a problem or not. Reading the description for this option would lead me to believe that your ISP may have something misconfigured.

    RDNS should be set for your main IP to be your server name. Which will normally be something like server.domain.com. The name you gave it when you first set it up. All email for all your domains gets sent from this IP and server so when it is checked at the receiving end it will be valid. If you will never host additional domains then setting your server up as domain.com with RDNS to domain.com and using all of the VPSs resources for that one domain would be what you have done.
     
  10. ejellard

    ejellard New Member

    Hi,

    Thanks for the reply - I agree that my ISP have probably done something strange, but it's working nicely anyway!

    As far as the reverse dns goes - I'm planning on having at least three domains hosted on the one IP address, and would like to be able to send email from them all (although I've setup Google apps for two of them) - does that mean I should ask knownhost for domainA.com, domainB.com and domainC.com to all be pointed from my one IP - or should just the nameserver subdomain be pointed to, or something totally different!?

    Cheers,
    Ed
     
  11. khiltd

    khiltd New Member

    Multiple names can map to a single IP but the IP can only map to one name. If you want reverse lookups for all three domains you'll have to buy three IPs.
     
  12. Dan

    Dan Moderator

    Ed,

    RDNS for an IP can only be set up to point to one domain, not multiple.

    You should have 2 IPs for your server. One of which is the main or shared IP. RDNS should be set for that IP to point to your server name server.domain.com.

    Then all outgoing email for all of your domains is sent from the server and on the receiver's end it will be validated as having RDNS. If you set up SPF for your domains then it will also be valid in reference to that IP.

    When configuring your nameservers you can set one to each of the 2 IPs and register them at your registrar.

    On my VPS I have 2 IPs.
    1 has been set as the main shared IP for the server.
    The VPS host name has been set to whatever.myhostingdomain.com.
    RDNS was configured to point to whatever.myhostingdomain.com.
    I then configured 2 nameservers ns1 and ns2.myhostingdomain.com which I then set up at godaddy.

    Then whenever I create a new domain RDNS is already taken care of in the prior steps and the nameservers are put into the zone records automatically. MX records are also created automatically and everything is run off of the main shared IP.

    Hope that helps
     
  13. ejellard

    ejellard New Member

    Thanks for the reply - it certainly does help, and feel free to ignore the next part of my misunderstandings!

    Is that the bit that will allow other domains to get reverse dns? At the moment, my ns1.domainA and ns2.domainA are "glue" domains, or whatever it's called - pointing to my primary/secondary IP address/VPS, which is running BIND - so I can't see how I would get reverse DNS for my non-primary domains!

    Maybe I should go and get a DNS book from the library!!

    Cheers,
    Ed
     
  14. khiltd

    khiltd New Member

    You wouldn't unless you purchased dedicated IPs for them.
     
  15. ejellard

    ejellard New Member

    Ah ha - now I understand, thank you very much!
     
  16. Dan

    Dan Moderator

    Ed,

    I hope you didn't run off and buy dedicated IPs for each domain because you do not need this unless you want to run SSL for them...
     
  17. ejellard

    ejellard New Member

    Nope - didn't buy them, just twigged the 1 to 1 relationship for reverse dns!
     
  18. ok0510

    ok0510 New Member

    ppc, I changed the sshd_config file to one from my local fedora install, and used "UseDNS no" and it is now flying - I think as I don't have a static IP address and no reverse dns entries on my home internet connection, there were some strange problems.
     

Share This Page