SpamAssassin update (problem?)

Discussion in 'Linux VPS/Dedicated - cPanel' started by turbo2ltr, Sep 28, 2010.

  1. turbo2ltr

    turbo2ltr Member

    So ever since the cpanel update on the 8th, I'm getting flagged that the nightly cpanel updates fail. By flagged I mean that I have my email client set up to flag logs that contain any of a bunch of bad keywords such as "warning", "error", "failed", etc.

    Ever since the cpanel update on the 8th, I have this in the update log:

    Code:
    [COLOR=#000000][FONT=Times New Roman][FONT=arial]Updating SpamAssassin rules...Running sa-update (/usr/local/bin/sa-update).....[22299] dbg: logger: adding facilities: all
    [22299] dbg: logger: logging level is DBG
    [22299] dbg: generic: SpamAssassin version 3.2.4
    [22299] dbg: config: score set 0 chosen.
    [22299] dbg: dns: no ipv6
    [22299] dbg: dns: is Net::DNS::Resolver available? yes
    [22299] dbg: dns: Net::DNS version: 0.66
    [22299] dbg: generic: sa-update version svn607589
    [22299] dbg: generic: using update directory: /var/lib/spamassassin/3.002004
    [22299] dbg: diag: perl platform: 5.008008 linux
    [22299] dbg: diag: module installed: Digest::SHA1, version 2.12
    [22299] dbg: diag: module installed: HTML::Parser, version 3.65
    [22299] dbg: diag: module installed: Net::DNS, version 0.66
    [22299] dbg: diag: module installed: MIME::Base64, version 3.09
    [22299] dbg: diag: module installed: DB_File, version 1.814
    [22299] dbg: diag: module installed: Net::SMTP, version 2.31
    [22299] dbg: diag: module installed: Mail::SPF, version 2.007_001
    [22299] dbg: diag: module installed: Mail::SPF::Query, version 1.999001
    [22299] dbg: diag: module installed: IP::Country::Fast, version 604.001
    [22299] dbg: diag: module not installed: Razor2::Client::Agent ('require' failed)
    [22299] dbg: diag: module not installed: Net::Ident ('require' failed)
    [22299] dbg: diag: module not installed: IO::Socket::INET6 ('require' failed)
    [22299] dbg: diag: module installed: IO::Socket::SSL, version 1.33
    [22299] dbg: diag: module installed: Compress::Zlib, version 2.03
    [22299] dbg: diag: module installed: Time::HiRes, version 1.9721
    [22299] dbg: diag: module installed: Mail::DomainKeys, version 1.0
    [22299] dbg: diag: module installed: Mail::DKIM, version 0.38
    [22299] dbg: diag: module installed: DBI, version 1.609
    [22299] dbg: diag: module installed: Getopt::Long, version 2.38
    [22299] dbg: diag: module installed: LWP::UserAgent, version 5.834
    [22299] dbg: diag: module installed: HTTP::Date, version 5.831
    [22299] dbg: diag: module installed: Archive::Tar, version 1.68
    [22299] dbg: diag: module installed: IO::Zlib, version 1.10
    [22299] dbg: diag: module installed: Encode::Detect, version 1.01
    [22299] dbg: gpg: Searching for 'gpg'
    [22299] dbg: util: current PATH is: /usr/bin:/bin:/sbin:/usr/sbin:/usr/bin:/bin:/usr/local/bin
    [22299] dbg: util: executable for gpg was found at /usr/bin/gpg
    [22299] dbg: gpg: found /usr/bin/gpg
    [22299] dbg: gpg: release trusted key id list: 5E541DC959CB8BAC7C78DFDC4056A61A5244EC45 26C900A46DD40CD5AD24F6D7DEE01987265FA05B 0C2B1D7175B852C64B3CDC716C55397824F434CE
    [22299] dbg: channel: attempting channel [URL="http://updates.spamassassin.org/"]updates.spamassassin.org[/URL]
    [22299] dbg: channel: update directory /var/lib/spamassassin/3.002004/updates_spamassassin_org
    [22299] dbg: channel: channel cf file /var/lib/spamassassin/3.002004/[URL="http://updates_spamassassin_org.cf/"]updates_spamassassin_org.cf[/URL]
    [22299] dbg: channel: channel pre file /var/lib/spamassassin/3.002004/updates_spamassassin_org.pre
    [22299] dbg: channel: metadata version = 895075
    [22299] dbg: dns: [URL="http://4.2.3.updates.spamassassin.org/"]4.2.3.updates.spamassassin.org[/URL] => 895075, parsed as 895075
    [22299] dbg: channel: current version is 895075, new version is 895075, skipping channel
    [22299] dbg: diag: updates complete, exiting with code 1
    Done[/FONT][/FONT][/COLOR]
    It does this every night. You can see that there are three lines that say "failed".
    Code:
    [22299] dbg: diag: module not installed: Razor2::Client::Agent ('require' failed)
    [22299] dbg: diag: module not installed: Net::Ident ('require' failed)
    [22299] dbg: diag: module not installed: IO::Socket::INET6 ('require' failed)
    The odd thing is I don't use SpamAssassin. I have it disabled in WHM under services and tweaks. So why is it updating the rules? Can I turn this off? Or can it be fixed?

    Thanks,
    Mike
     
  2. turbo2ltr

    turbo2ltr Member

  3. Dan

    Dan Moderator

    Thanks for catching that turbo2ltr :)
     
  4. turbo2ltr

    turbo2ltr Member

    Turning off the automatic updates did "fix" the problem.

    thanks..
     

Share This Page