Some early snags - hard link count, SSH, and public html issue

Discussion in 'Linux VPS/Dedicated - General' started by marcm, Apr 12, 2008.

  1. marcm

    marcm Member

    Hello again,

    Well, I'm making some great headway getting this VPS setup. However, I've come across some snags and I figure I'll start here before contacting support.

    Ok, first of all, when I setup a package in cpanel, and then added an account, I was able to add a basic html file which would come up and replace the welcome to cpanel page. I have not re-routed the URL to my new DNS nameserver address yet because I just want to test things out with the IP first. I received an email alert from cPanel saying my hostname isn't resolving to my IP, but to my old IP. Then it says what to check etc. So now when I visit the IP in a browser, it reverts back to the cPanel welcome screen as opposed to my site's temp index.html page. I hope this has to do with the dns problem, but if not I'm stumped. I'm wondering if I can fix it without having to setup the nameservers yet?

    (what's weird is that it seems to route the browser to /user/local/ something as opposed to /root/public_html - and what I want is
    /home/myaccount/public_html to display when I visit my main IP in a browser.

    Another problem I'm getting when connected via SSH secure shell is a warning: Hard Link count is wrong for /proc/vz/vzaquota: this may be a bug in your filesystem driver. Automatically turning on find's -noleaf option. Earlier results may have failed to include directories that should have been searched. This error comes up when I do a find and also when I the chkrootkit.

    Finally, I've always used a password when connecting via SSH secure shell, but I decided I'd try to secure it with a paired key setup. I generated a pair of keys via Secure Shell and then used it to upload to /root/.ssh2 (I also uploaded it to .ssh along with the authorization file. I can see the key in WHM now. But if I try to connect without the password, it still requires it, so i'm missing something here. Can it be done simply via WHM and/ or my Secure Shell or do I need to modify some files on the server?

    Thanks for your help if you can. I'd really like to get the directory working again so i can start testing again.

    -Marc
     
  2. khiltd

    khiltd New Member

    Name based virtual hosting only works when the names do. If you want to view a specific account before this happens you'll need mod_userdir. If you want the IP to go straight to a specific account then you'll need to tweak your global Apache config.

    For the other problems you should probably file a support ticket.
     
  3. marcm

    marcm Member

    Hmm ok. I wonder why it was working fine yesterday then?

    I'll look into mod_userdir and global Apache config.
     
  4. marcm

    marcm Member

    Well, support was quick to help me. :) They simply changed the order of my virtual host entries. This will work for me in the short term until i'm ready to point the domain to my new IP. (still not sure why it was working yesterday lol)

    If I find anything out about the other error I'll report back here.

    update: The error:
    warning: Hard Link count is wrong for /proc/vz/vzaquota: etc.
    Is a normal error with VPS it seems, so nothing to worry about.
     

Share This Page