SMTP Settings

Discussion in 'Linux VPS/Dedicated - cPanel' started by mapenn, Mar 4, 2007.

  1. mapenn

    mapenn Member

    Hi -- I have a question on SMTP settings. I have a test email account setup and it sends/receives OK with webmail. From my PC (using Thunderbird), I can receive OK. However, I can not SEND.

    I can't find any KB articles or forum topics on SMTP settings. Is there anything that I need to know about?

    This is my first VPS, so I apologize if I am asking an obvious question! :)
     
  2. Bryan

    Bryan Very Happy KH VPS User

    If it absolutely won't work, there is the high probability that your ISP is blocking port 25 (the standard SMTP port). If that's th case, change the exim settings so that Exim also runs on port 26. Then in your e-mail client, set it to use port 26 instead of port 25.
     
  3. mapenn

    mapenn Member

    Yeah, that's most likely the problem.

    I can access the exim editor with Cpanel. However, I have no idea where or what to edit within this configuration file. Can anybody help here? Thanks!
     
  4. KH-Paul

    KH-Paul CTO Staff Member

    There is no need to do manual reconfiguration of exim, cPanel can handle this for you. Just go to WHM >> Service Configuration >> Service Manager, scroll to the very bottom and enable the "exim on another port" option, then click "Save".

    Regards,
    Paul
     
  5. mapenn

    mapenn Member

    That was exactly what I needed. Thanks!
     
  6. khiltd

    khiltd New Member

    Doesn't this simply invoke another copy of the daemon with different command line arguments?

    If you want to do it from the config file, you'd need something like

    Code:
    daemon_smtp_ports = 25 : 2525 : 587
    Substituting whatever port you wanted in place of the 2525.
     

Share This Page