Setting Mx records using Godaddy as host

Discussion in 'Linux VPS/Dedicated - cPanel' started by David, Jun 6, 2014.

  1. David

    David New Member

    Hi, I have the DNS set as the default godaddy servers. I have an A record pointing all traffic to Knownhost VPS IP. What settings do I use to get the MX records and mail to come to Knownhost IP too?
     
  2. Dan

    Dan Moderator

    Hi David,

    Once you create an account on your server it creates MX records for the domain automatically. Then after creating your name servers at your registrar and pointing your domain to them it should automatically use the new MX records.
     
  3. phpAddict

    phpAddict Active Member

    If you're going to be sending both web and email traffic to your KH's server, why not just use the nameservers? That'll point web, email, ftp, and everything.
     
  4. Dan

    Dan Moderator

    >.< I totally read it as that was what he was doing!
     
  5. David

    David New Member

    I would normally - but that takes time to filter through and this is a last minute setup for a FIFA world cup competition. I have found changing the DNS servers take 1-2 days, but pointing the IP can take only hours. So was wondering if I could setup the same MXrecords on godaddy that would be present on Knownhost if I had changed the DNS
     
  6. phpAddict

    phpAddict Active Member

    They'll propagate the same if you've already set up your nameservers. If you need to still set host records for your nameservers then yea it would take a little longer as your nameservers would need to propagate first, then the domain.

    There's less time filtering for nameserver changes then there is to change dns records with godaddy. You'll find setting nameservers is more convenient and faster than pointing individual dns records. Below is all you need to set and your KH server will handle the rest, your website, email, ftp, everything will work just as Dan said your server creates them all automatically.

    acdn6.whealmedia.com_wp_content_uploads_godaddy_nameserver_steae4b4ce088b5bfe00ab4721d2c90e70d.png
     
  7. David

    David New Member

    Thanks, I'll try it
     
  8. David

    David New Member

  9. owine

    owine New Member

    It resolved to KH for me and I see no issues with your DNS configuration. Most likely the DNS resolvers your client machine is using are caching or your local machine is caching. I would try clearing your local DNS cache and see if that helps.

    For future reference, you can help prevent caching issues by reducing the TTL on DNS entries that will be changing in the near future. This will cause compliant caching mechanisms to cache for a shorter period of time before a direct query. It effectively acts as a flag to alert the internet that a change is coming so check in more often.
     

Share This Page