safe mode master value

Discussion in 'Linux VPS - Plesk' started by rezag, Dec 11, 2007.

  1. rezag

    rezag New Member

    I was thinking of asking via a ticket but I thought about posting.

    I set safe mode off when creating domains via CP (I have Plesk), but when looking at phpinfo I notice that the master value is on. I know that local value off should work but am wondering if the master value on could somehow intefere or conflict.
    The reason this came up is I am trying to use loadavg but the cron output has this (among other lines)
    PHP Warning: file_get_contents(): SAFE MODE Restriction in effect. The script whose uid is 10001 is not allowed to access /proc/meminfo owned by uid 0 in /var/www/vhosts/XXXXX.com/httpdocs/loadavg/logger.php on line 88
     
  2. khiltd

    khiltd New Member

    It completely defeats the purpose if individual users are allowed to override the global safe_mode setting, so unless you're allowing everyone to use their own php.ini it's probably not going to work the way you want it to.
     
  3. rezag

    rezag New Member

    Thanx for the reply, understood :)
    I guess this probably means that my problem running loadavg is not fully related to the safe mode error I posted above because there are others right here at KH using loadavg without any issues and as far as I know (I initially spoke via PM to pmcwebs who had posted the link to loadavg here) without changing any settings 'out of the box'.
     
  4. khiltd

    khiltd New Member

    Every control panel has a different set of "out of the box" settings for PHP (and then there are various options like running it as mod_php, running it as a CGI process, running it as a CGI process with suexec, running mod_suphp etc), so you really have to take a look at your specific configuration and see what needs to be done.
     
  5. rezag

    rezag New Member

    Yes true, I am trying to figure it out. Also wrote to loadavg's author, the script is not supported of course but worth a shot.
     
  6. KH-Paul

    KH-Paul CTO Staff Member

    rezag,

    With Plesk you can enable/diable safe_mode on per domain basis by checking/unchecking the safe_mode checkbox at Plesk CP -> Domains -> domain.com -> Setup. More information about this and other site hosting related option can be found in Plesk manual
     
  7. rezag

    rezag New Member

    I have when I set up the domains, I believe thats why the local value is off. I wondered about the master value, of course the script I was referring to shouldn't be using it or need it but nevertheless I was wondering about the master value.
     

Share This Page