Qs about WHM, DNS Zones, and Nameserver setup

Discussion in 'Linux VPS/Dedicated - cPanel' started by marcm, Apr 14, 2008.

  1. marcm

    marcm Member

    Ok, I have a few questions about WHM and my VPS that maybe someone could assist me with. (I've read all of the DNS messages on this forum btw)

    First, in DNS Zones. Say my host name is host.mydomain.com

    do I need a DNS Zone for both host.mydomain.com and for mydomain.com? (or is this just going to confuse the server?) Doesn't feel right.

    When I choose "Add an A entry for your hostname" It shows the
    host.mydomain.com
    short hostname to host,
    domain to mydomain.com
    and IP.
    I've done this a few times. I'm almost certain that the A record is correct in the mydomain.com zone.

    When I run the add entry, it says:
    "Bind reload skipped on host (nameserver disabled)"
    Is that normal?

    If I edit the zone file for mydomain.com, It shows: (noting A records only)
    mydomain.com 14400 in A my IP
    localhost.mydomain.com 14400 in A 127.0.0.1 (local IP)
    host.mydomain.com 14400 in A - my IP (this seems to be the one added when choosing Add an A record for your Hostname

    and finally I added
    host 14400 in A my IP (which prob doesn't do anything but can it hurt?)

    (interesting how the entries for the domain itself all have (.) periods after the name - along with the nameservers )
    mydomain.com. 86400 in NS ns1.mydomain.com.

    Ok back to the Nameserver disabled error. I've gone back and forth with the 'Enable Nameserver' setup under Server configuration. I've enabled it and disabled it. What's the deal here. Do I need it enabled for things the function properly? (in service manager should named, Berkely Name Server Daemon be check enabled) I get the feeling that I don't need to enable this for the VPS to function properly.

    So, any feedback on this stuff?
     
  2. khiltd

    khiltd New Member

    You don't need two A records for the same thing. You would typically have a single A record pointing the base host name to your IP followed by several CNAME records aliasing things like "www", "mail" and "ftp".

    Not so much interesting as imperative. BIND appends the implied zone origin to all names in the zone file which do not end in a dot, and omitting it will cause no end of problems.

    You absolutely need BIND enabled for anything to work unless you happen to be using an external nameserver. Generally speaking, you really shouldn't ever touch your zone files if you can't read them. cPanel gets it close enough for most people.
     
  3. marcm

    marcm Member

    First of all, Thanks to Mike from KH Support - was very helpful. Thanks Mike!

    I'll answer my own questions here for those that may have the same issue later...

    First, in DNS Zones. Say my host name is host.mydomain.com

    do I need a DNS Zone for both host.mydomain.com and for mydomain.com? (or is this just going to confuse the server?) Doesn't feel right.


    I only needed one DNS for mydomain.com.

    When I choose "Add an A entry for your hostname" It shows the
    host.mydomain.com
    short hostname to host,
    domain to mydomain.com
    and IP.
    I've done this a few times. I'm almost certain that the A record is correct in the mydomain.com zone.

    I had host.mydomain.com as n A entry and I also had just 'host' as an A entry pointing to my first IP. I only needed 'host'

    When I run the add entry, it says:
    "Bind reload skipped on host (nameserver disabled)"
    Is that normal?

    Named service was giving an error because the Zone file was incorrect.

    If I edit the zone file for mydomain.com, It shows: (noting A records only)
    mydomain.com 14400 in A my IP
    localhost.mydomain.com 14400 in A 127.0.0.1 (local IP)
    host.mydomain.com 14400 in A - my IP (this seems to be the one added when choosing Add an A record for your Hostname

    and finally I added
    host 14400 in A my IP (which prob doesn't do anything but can it hurt?)


    again 'host' A record is correct and not 'host.mydomain.com'

    The main thing I was missing was a ns1 and ns2 A entry. It wasn't there and I had no clue to add it. No information I came across said to add it but Mike put it in there. (I would've never guess randomly to try that)

    ns1 14400 IN A xx.xxx.x1.xx
    ns2 14400 IN A xx.xxx.x2.xx

    Doing that and starting the service fixed the glitch! Woohoo thanks Mike!
     
  4. marcm

    marcm Member

    Khiltd, Thanks for your feeback. I was writing the other reply when you posted yours. Thanks for the info about the BIND and zone origin. I guess I just couldn't get BIND to work without the proper ns1 and ns2 A entries. I'm very happy with the support here so far and I'm relieved to have the basic server/domain up and running. Phew.
     
  5. khiltd

    khiltd New Member

    It's been a while since I went through it all from scratch, but you should have created records for your nameservers as part of the initial WHM setup.
     
  6. marcm

    marcm Member

    I suppose but I don't know if I had a DNS zone file until after I created the main IP account, and that's where the problem was.
     

Share This Page