PHP upgrade from 4 to 5 Problem

#1
Not sure if this is the correct forum. I am transferring an existing Guest Book from my old host that uses PHP 4.4.7 on to my new VPS that uses PHP 5.2.5 and I seem to be getting a connection error as a result of this. Both are using cPanel and the guest book is the PHP "Advanced Guestbook". Actual error details are:

Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'xxx'@'localhost' (using password: YES) in /home/xxx/public_html/guestbook/lib/mysql.class.php on line 23
Error Number: 1045 Access denied for user xxx (using password: YES)
Referer : http://xx.xx.xx.xx:2086/scripts2/tweaksettings
PHP Version : 5.2.5

I have been referred to tweak settings in my control panel but I am unsure what setting to tweak - can anyone please help me.

Much appreciated
 
#2
The error you are getting is a MySQL error. The database user that the script has set up to access the database seems like it has incorrect authentication information.
 
Top