php moving files and permissions

Discussion in 'The Lounge' started by mofolo, Jun 7, 2010.

  1. mofolo

    mofolo New Member

    Hey there,

    I just upgraded from shared to KH VPS..

    Now my website's code seems to be broken in some place (which I have come to expect).

    The most puzzling is this error:

    It seems like a permission problem.

    I understand that I can change the permissions to allow 'other' write permissions, but I'd like to know if there is a way to make the website think that the php scripts are run under 'owner'?

    Thanks.
     
  2. Dan

    Dan Moderator

    Hello Mofolo,

    Sounds to me like you need to enable suPHP.

    In WHM go to Service Configuration | Apache Configuration | PHP and SuExec Configuration

    Then make sure the default PHP version is set to 5 and for the PHP handler select suPHP and set Apache suEXEC to On.

    Save the new configuration and you should be good to go!
     
  3. mofolo

    mofolo New Member

    ... I love you Dan!

    Worked like a treat!

    Thank you so much!
     
  4. mofolo

    mofolo New Member

    Just 1 more thing:

    Now when I run phpinfo() it returns a 500 internal error..

    Any suggestions?
     
  5. Dan

    Dan Moderator

    When you upload the file do you upload it as root and then try to run it as a user? Be sure to chown it to the user whose account you put it into :)
     
  6. exoexo

    exoexo New Member

    Thanks a lot! I was just wondering how to make all my websites save files and started chmod 777 folders, but there are 100s folders to chmod. And you saved me ;) Now looks like scripts again can save files as they did before at stupid shared lol
     
  7. vuong184

    vuong184 New Member

    Thanks! Dan :D
     

Share This Page