php.ini and allow_url_fopen

Discussion in 'Linux VPS/Dedicated - General' started by bubinski, Feb 4, 2009.

  1. bubinski

    bubinski New Member

    I'm playing around with some new software on my site that requires "allow_url_fopen=on". However, I've disabled this in my php configuration settings in WHM by setting "allow_url_fopen=off".

    I'm aware that on some servers one can override that by placing a php.ini file in each subfolder where you wish to override and using "allow_url_fopen=on" in the "php.ini" file. I would like to have "allow_url_fopen=on" in those subfolders and I've place "php.ini" files in all those subfolders however when I run the software I'm testing I keep getting the error message that "allow_url_fopen" is still turned off.

    I'm still learning about Apache and I'm pretty rusty at it. I thought if one has AllowOverride All in the http.conf file this allows one to override some settings by using php.ini files. Am I wrong on this? I'm thinking I've got something not right in my http.conf file. Any suggestions? Thanks for any info.
     
  2. bubinski

    bubinski New Member

    And along those lines, with "allow_url_fopen=off" in the php.ini file, it is supposed to still allow access to "local" files when "fopen" is used in a php script. However, I've tested some scripts and they always fail to allow "fopen" to open local files.

    I'm at a loss here as to why this occures. Because the only way to read remote files (http://......) with "allow_url_fopen=off" is to use CURL in my php scripts. However, CURL still uses fopen to open local files for writing after it reads in remote files. My CURL read code works fine but I should be able to at least use fopen to open a local file for writing even if "allow_url_fopen=off" but it won't open any local files.

    I keep thinking there's some other setting I'm missing in my http.conf or in WHM but I've gone over everything several times and can't find anything wrong in my setting. I've simply got "allow_url_fopen=off" set in my php.ini file through the WHM Admin Panel and it really turns off everything to do with "fopen".
     

Share This Page