Newbie in Need! All email going to Hotmail Junk folder on VPS domains

Discussion in 'Linux VPS/Dedicated - General' started by inquiring_mind4u, Jul 18, 2007.

  1. inquiring_mind4u

    inquiring_mind4u New Member


    I have a new VPS account and have set-up one domain.

    From day one I've been unable to get email to go through to Hotmail's Inbox. It all goes to junk (I've tested the message content on other servers and know the content is OK). Also, I know that my IP isn't blacklisted anywhere. And I've sent test messages using POP3 and PHP's mail() function.

    After some massaging of the DNS records, adding some new ones, and creating SPF records for both and, I've gotten email to go through to the inboxes of all other big service providers (Yahoo, AOL, & GMail all are OK), but Hotmail still sends it to Junk.

    Normally I wouldn't be concerned with just one provider routing messages to Junk, but in the case of Hotmail, their members usually comprise 15% of any mailing list.

    FYI: I've also used to troubleshoot my domain ( to help fix the problems that happen when any new domain account is created through CPanel (it's surprising to me that out of the box it doesn't create sufficient DNS records). My configuration is now to the point where all the important tests are passing.

    I'm a newbie at this... and I was under the impression that the hosting accounts created on the VPS platform would be Web & Email-friendly out of the box. Unfortunately KnownHost support said it's my job to figure out why Hotmail doesn't like the email. It's a major disappointment to find out that I'll have to get this working on my own.

    Have you tested your VPS / CPanel-created accounts to see if your email gets through to Hotmail's inbox?

    Any idea what needs to happen to get Hotmail to accept email from my server?

    Thanks a lot.

  2. NeilHerbert

    NeilHerbert YummyHost

    Hi Tim,

    This is unfortunatly a big problem for most people. I found that SPF records did nothing for hotmail, but a slight modification to the webmail clients that I have installed under cpanel (squirrel and roundcube) you can get hotmail accepting mail. Hotmail's filters are extremely annoying, it was getting to the point where emails from my server were not even getting junked, they were being dropped before they even reached the mailbox.

    I didn't seem to have a problem with emails being sent from a php script, only from cpanel's webmail. Anyway try this, when using squirrelmail; tick the Receipt On Read box, or while in horde; Request a Read Receipt, if you've installed Roundcube (it's much better than horde or squirrel); tick Return Receipt. Hopefully this should sort the problem. If it does go into the /usr/local/cpanel/base/ and edit the compose email scripts for each webmail client to have those boxes ticked by default. These options seem to trick the filters into thinking your replying to an email or something. It fixed it for me.

    Hope this helps,

  3. magic

    magic New Member

    do you have rDNS set up for your host? that's another thing they check for
  4. Aussie_Boy

    Aussie_Boy Member

    lucky you!

    about 45% of my mail list comprises hotmail users.

    anyway, back to the topic at hand. did you submit your (spf'd) domains to hotmails email service?

    it may help as that's what their web site informs ppl to do (it didn't help me but it may help you).
  5. Aussie_Boy

    Aussie_Boy Member

    I wonder if this can be done in php mail() somehow!

    Found two examples, not sure if one is better or if one isn't supported:

    Return-Receipt-To: [email protected]\r\n
    Disposition-Notification-To: Your Name<[email protected]>n

  6. Dan

    Dan Moderator

    I had thought I was having problem sending to Hotmail as well for a couple of years now. I had PTR set up and also SPF to no avail. Then I ran across a post on CPanel's forums that said they also block on email SIZE. As a matter of fact just the difference in size between an HTML mail and a text mail would make a difference as the one composed in HTML would go through but not the text one. So when you send a test message don't send just "test".

    Hope that helps

Share This Page