Joomla Driving Me CrAzY! Permissions/Ownership Problem

Discussion in 'Linux VPS/Dedicated - cPanel' started by scottiedog, Aug 18, 2010.

  1. scottiedog

    scottiedog New Member

    Hey Guys,

    I don't usually use my VPS plan for anyone else but myself, however I have been helping out a friend who wants to run Joomla. There is an issue with permissions, as far as I have read on the internet, this is a pretty common issue with Joomla. I am treading a lot of new water here, so sorry for the newbie-ness of this...

    I am running PHP5, PHP 5 Handler is set to dso, suExec is set to on.

    Now, my friend mentioned he believes to run Joomla, the ownership should be set to joomla:apache or something similar... I was thinking it might need to be set to accountname:apache, I tried doing this through SSH with no luck and then through vz/cp I see I can change the ownership permissions but this would take a million years due to the fact it has to be done for each file.....

    So, I guess what I am asking is, does anyone have the steps to get Joomla to run on the Knownhost VPS plan?

    Thanks in advance!
     
  2. Dan

    Dan Moderator

    Hi there Scottiedog,

    I run my own Joomla site and host a couple of sites using Wordpress and here I have PHP set to suPHP and Apache suEXEC is On. I've never had to mess with ownerships or permissions other than just following the installation instructions. Everything is owned by user:user.

    If I remember correctly the normal ownership is user:nobody and anything installed will typically be owned correctly but sometimes permissions do need to be massaged.
     
  3. jke

    jke New Member

    I'm certainly no expert so be forewarned, but I do run many Joomla installs on my VPS and will share my settings.

    In my case for each install, public_html ownership is set to user:nobody and all directories and files under that are set to nobody:nobody. Whenever I have it set differently it causes problems. (Apache settings - PHP 5 Handler is set to dso, suExec is set to on.)

    Permissions on folders are:
    public_html - 0750
    all directories under this - 0755

    BTW my experience is if you install using a backup created by akeeba (most usefull extension ever) it will autoset the correct permissions and ownership - even if they were incorrect when the backup was taken.

    When updating a Joomla install, (after taking a backup) I sh in as root using PuTTy, navigate to the namespace, then from owner/public_html run the following >> chown -R owner: * then upload the updated files through sftp. After updating I run the same command using "nobody" in place of "owner". This all seems to work well for me and is becoming routine and fast.
     
  4. inveress

    inveress New Member

    Scottie,

    I had permission problems with Joomla (and, in fact, many other things) until I turned suPHP on. I can't say that it would definitely solve your problem but it may be something to consider.

    Peter.
     
  5. mrbshouse

    mrbshouse New Member

    having some issues here to not sure at all what is causing them

    I get Joomla in fine, but can not add components like CB 1.4 or CiviCRM followed the tips listed above, still no joy :confused:
     
  6. Dan

    Dan Moderator

    Hi mrbshouse,

    Did you enable suPHP and suEXEC? That should fix all of your permissions problems so long as everything is owned by the correct user.
     
  7. mrbshouse

    mrbshouse New Member

    yeah i did go that route, had most of my sites up following a recompile, but lost two OScommerce sites, now I can't install much getting php_flag errors on most installs manual or through fantastico.

    im ready to switch back already lol

    any good tutorials out there?


    added the php.ini, but didn't really change anything from the previous server settings (googeld the error) any links to good info??? searching here thinking it's something specific to KH.....
     
  8. Dan

    Dan Moderator

    mrbshouse,

    I am not seeing where you gave us the error. Normally what is show in the Apache error log is most informative and after changing to suPHP they are almost always permissions problems.
     
  9. mrbshouse

    mrbshouse New Member

    ok see there ya go just a newbie here, trying to take the reigns. I'll look for the apache errors now, but im not thrilled fantastico installs are down those should still work right? :rolleyes:
     
  10. Dan

    Dan Moderator

    I would sure think they would still work, yes. Perhaps your best bet would be to simply shoot a ticket into support and see what they say. Just let them know what you've done (switched to suPHP & suEXEC) and whatever else you've done after that. Sometimes their 10 minutes is worth 2 hours for me LOL
     
  11. mrbshouse

    mrbshouse New Member

    ok im looking for the Apache errors now, was just looking at the cpanel errors before. any good tutorials to point me to?


    really disappointed that fantastico can't install now, must be a pretty basic setting that is wrong.
     
  12. Dan

    Dan Moderator

    You should find the Apache error log at /usr/local/apache/logs/error_log.
     
  13. mrbshouse

    mrbshouse New Member

    yeah well my tellnet skills aren't the best. do you know of a good tutorial on how to read them, i tried searching a few times, but honestly i don;t even know how to get that high in the server file structure lol.
     
  14. Dan

    Dan Moderator

    You will need to SSH (I use Putty) into your VPS as root and then view the file using something like
    Code:
    pico /usr/local/apache/logs/error_log
    Once in the file you can use your Page up/down keys to find what you need or Ctrl-W is find if you know what to search for. Highlighting what you want will copy it to the clipboard so you can paste it elsewhere. Ctrl-X is exit and if it prompts you to save changes just hit N for no or enter if you made changes and want to save them.
     
  15. Zenin

    Zenin New Member

    Hey!
    its not just you.. something has changed with the server!

    i have already got wordpress and joomla installs,and they install perfect work fine

    i tired installing both joomla and wordpress THIS week and they both get permission errors and no amount of chmod'ing is fixing it, php.ini files don't work.

    This is a server issue.

    p.s. my old installs don't have any upload errors. so it seems to be only on new installations.
     
  16. Dan

    Dan Moderator

    Morning Zenin,

    Well if it worked before and doesn't now it sounds like maybe a cPanel update went wrong or something. Assuming you didn't make any changes such as disabling suPHP or suEXEC that is. If it is a cPanel update gone wrong then it would hopefully be fixed within a day or two but you can always shoot a ticket into support and ask that they look at it.
     
  17. Zenin

    Zenin New Member

    yeah i havn't messed around with suPHP or suEXEC, (never even heard of it before today)

    Will submit a ticket, Thanks Dan.
     

Share This Page