Installing Observium

Davor

New Member
Hi

Did someone tried to install http://www.observium.org/ on VPS? I see that CentOS is not supported, so it confuses me, I stuck on step where I need to update config.php fo database.

I tried to install it as a subdomain of my main domain, is that OK?
I'm not an unix expert and even they say that 'install is pretty simple', I didn't see it that way :)

any tips?
thanks
 

KH-Chad

Banned User
Staff member
Hi Davor,

I haven't installed it personally but from the documentation installing it on a subdomain shouldn't be an issue.

Are you having issues with running the update.php script for updating the database, or adding fping to the config file?
 

Davor

New Member
Hey Chad,

Yeah, I created manually db through cPanel, and stuck on adding fping. I will try today again and will see If goes ok this time :)
 

KH-Chad

Banned User
Staff member
Have you made sure that fping is actually installed on your server? If it is then you can use the which command to find the installation path, which should be used instead of the path that's in the install manual:

which fping

If it isnt installed then typing
fping
at the prompt will produce the results
-bash: fping: command not found
In which case, of course, it will need to be installed. That install information can be found at:
http://pkgs.org/centos-6-rhel-6/repoforge-i386/fping-2.4-1.b2.3.el6.rf.i686.rpm.html
 

Davor

New Member
Hey Chad,
fping wasn't installed and I installed it and I try to fping some ip and its working.

I can login into UI (I added user successfully), I'm stucked now on adding hostname, I updated community for localhost in snmpd.conf

Code:
com2sec local    localhost      <mykey>
com2sec mynetwork NETWORK/24      <mykey>

but I guess something is missing, because it can't find it


Code:
root@host [/home/user/opt/observium]# ./addhost.php localhost <mykey> v2c
Trying v2c community <mykey> ...
No reply on community <mykey> using v2c
Could not reach localhost with given SNMP community using v2c
Trying v2c community<mykey> ...
No reply on community <mykey> using v2c
Could not reach localhost with given SNMP community using v2c
 

Davor

New Member
Hi, thanks for dealing this with me :)

yes, snmp is running

Code:
root@host [/home/user/opt/observium]# service snmpd status
snmpd (pid  11693) is running...
I receive huge list if I do this
Code:
snmpwalk -v 1 -c <community> -O e localhost

I found support answer, saying that it could be missing sysObjectId
http://jira.observium.org/browse/OBSERVIUM-245

where I can find this Id?
I tried adding both localhost or host name with firewall disabled and its the same
 

KH-Mathew

Systems Administration
Staff member
Check out http://www.net-snmp.org/docs/man/snmpd.conf.html

Most of the information reported by the Net-SNMP agent is retrieved from the underlying system, or dynamically configured via SNMP SET requests (and retained from one run of the agent to the next). However, certain MIB objects can be configured or controlled via the snmpd.conf(5) file.
System Group

Most of the scalar objects in the 'system' group can be configured in this way:
sysLocation STRING
sysContact STRING
sysName STRING
set the system location, system contact or system name (sysLocation.0, sysContact.0 and sysName.0) for the agent respectively. Ordinarily these objects are writeable via suitably authorized SNMP SET requests. However, specifying one of these directives makes the corresponding object read-only, and attempts to SET it will result in a notWritable error response.
sysServices NUMBER
sets the value of the sysServices.0 object. For a host system, a good value is 72 (application + end-to-end layers). If this directive is not specified, then no value will be reported for the sysServices.0 object.
sysDescr STRING
sysObjectID OID
sets the system description or object ID for the agent. Although these MIB objects are not SNMP-writable, these directives can be used by a network administrator to configure suitable values for them.
What you have in your snmpd.conf file?
 

Davor

New Member
I used the info from docs above


Code:
com2sec readonly  localhost        <mycommunity>
group MyROGroup v1        readonly
group MyROGroup v2c        readonly
group MyROGroup usm        readonly
view all    included  .1                              80
access MyROGroup ""    any      noauth    exact  all    none  none
syslocation "Mexico City, Mexico"
syscontact myemail@gmail.com
sysDescr "Description"
#This line allows Observium to detect the host OS if the distro script is installed
extend .1.3.6.1.4.1.2021.7890.1 distro /usr/bin/distro
 

KH-Mathew

Systems Administration
Staff member
Based on the thread that you posted a link to, I would try setting te sysObjectID in the config file.
 

KH-Mathew

Systems Administration
Staff member
See if this helps:

The correct value for a Net-SNMP agent on GNU/Linux is ".1.3.6.1.4.1.8072.3.2.10"

Taken from https://bugzilla.redhat.com/show_bug.cgi?id=641113
If setting the value to .1.3.6.1.4.1.8072.3.2.10 and restarting snmp does not fix the problem then lets see what dmesg and /var/log/messages say about the event. Try doing
Code:
dmesg|tail -f
In one terminal while adding the host in another terminal. You may also want to try
Code:
tail -f /var/log/messages
Just make sure that syslog is enabled in Observium as outlined here http://www.observium.org/wiki/Configuration_Options#Syslog_Settings .
I might would comment out the $config['syslog_filter'] option so syslog will be more verbose.
 

Davor

New Member
Hm, I think I will leave this for some other day :(

When i restart snmpd, I only see service restarted in /var/log/messages

Code:
Jul 15 09:32:12 host snmpd[24309]: Received TERM or STOP signal...  shutting down...
Jul 15 09:32:12 host snmpd[27869]: Duplicate IP address detected, some interfaces may not be visible in IP-MIB
Jul 15 09:32:12 host snmpd[27869]: NET-SNMP version 5.3.2.2
but no log when trying to add new host.
 

KH-Mathew

Systems Administration
Staff member
I am going to install on my VPS in the next few days. I will let you know if I can duplicate the issue. I will post back when I have had a chance to poke at it.
 

KH-Mathew

Systems Administration
Staff member
Hey Davor,

I got it running on my VPS

Code:
root@mathewm [/home/moon/public_html/observium]# ./addhost.php localhost public v2c
Trying v2c community public ...
 
Discovering localhost (1)localhost 1 linux  (unix)
Adding: lo(1)()Adding: venet0(2)()Adding: tun0(13)()
Discovered in 0.115 seconds
 
localhost 1 linux  (unix)
IPv4 Addresses : S+S+S+S+S+
Discovered in 0.162 seconds
 
localhost 1 linux  (unix)
IPv6 Addresses :
Discovered in 0.066 seconds
 
Added device localhost (1)
Did you do this (from http://www.observium.org/wiki/NetSNMPd_Client_Configuration)
wget http://www.observium.org/svn/observer/trunk/scripts/distro
mv distro /usr/bin/distro
chmod 755 /usr/bin/distro
If not, then this would be in line with the bug about RHEL not giving the sysObjectID. I think that sysObjectID is what they are actually referring to by
"identify your distribution via SNMP"
Also, just to make sure, you did use an actual string for <Community> right? Make sure you used the same string for <Community> in the smpd.conf and when adding the host.
 

Davor

New Member
Hi, yeah, I have distro in place, I also added that OPTION for redhat as instructed.

could it be something related with ports?
I tried disabling csf firewall
 

KH-Mathew

Systems Administration
Staff member
I am not sure about ports. It would seem that the firewall should not matter when using localhost, but I may be wrong. If disabling csf does not correct the issue then it is definitely not an issue with ports being blocked. Can you actually login to observium? Have you tried adding a different host?
 

Davor

New Member
Yeah, I can login, I even tried adding the host in UI, but its the same, I tried 'localhost' and 'host.mydomain.com', will check all the steps, maybe I jumped something.
 
Top