Getting blocked by ATT for abuse

Discussion in 'Linux VPS/Dedicated - General' started by BAlGaInTl, Apr 7, 2008.

  1. BAlGaInTl

    BAlGaInTl New Member

    Ok,

    So, today I noticed that my email to any ATT or sbcglobal email address gets bounced back immediately. There is a message in my inbox by the time I'm back to it from sending the email.

    with SBC I get a 553 error. With ATT I get a 550 and a message about being blocked for abuse.

    I only have a few small websites on my VPS...

    How can I track down what if anything is causing the problem?

    I submitted the information to ATT, but didn't know if perhaps one of my scripts is spamming... as far as I know... everything is up to date.
     
  2. khiltd

    khiltd New Member

    Assuming you have adequate SPF and SenderID records in your zone file, you'll have to talk to AT&T. They've been blocking a lot of people for no apparent reason lately.

    Also, if you happen to be an AT&T customer yourself, make sure you're not trying to send your non-AT&T mail through their SMTP server. They have a new system that doesn't like that.
     
  3. BAlGaInTl

    BAlGaInTl New Member

    I put in a ticket and as always KH was quick to help. It seems that a couple of my domains were full and mail was being bounced back. Mostly spam. So, it looks like I may have been blacklisted for that.

    ATT was quick to take action after my message. My IP should be off their RBL within 24 hours.

    As for Non-ATT mail using ATT SMTP server.... I don't have a choice. ATT doesn't even allow the use of a third party SMTP server. Unless I want to use a custom port for my mail server I guess...
     
  4. khiltd

    khiltd New Member

    Use TLS; 587 is wide open.
     
  5. BAlGaInTl

    BAlGaInTl New Member

    Care to explain that...

    I'm still pretty much a novice when it comes to the actual settings of the VPS.

    Thanks
     
  6. BAlGaInTl

    BAlGaInTl New Member

    Ok... I see that TLS = Transport Layer Security

    What do I need to do to set up my SMTP using that? Sounds like it is better than using the standard protocol anyway.
     
  7. Dan

    Dan Moderator

    Configure your email client to use TLS instead of straight SMTP. Your server should be ready to go with it unless you have the port closed.
     
  8. BAlGaInTl

    BAlGaInTl New Member

    I tried... doesn't seem to work.

    I'm not sure that exim and vm-pop3d support TLS. I think that switching to dovecot would solve my problem, but I'm wary of making such a large change and fubar'ing everything.
     
  9. khiltd

    khiltd New Member

    Exim certainly does. If you're operating sans control panel all it needs is:

    Code:
    daemon_smtp_ports = 25 : 587
    tls_certificate = /etc/ssl/yourcert.crt
    tls_privatekey = /etc/ssl/private/yourkey.key
    
    Whether or not you'll be able to roll your own certificate free of charge depends on the mail client you use.

    Or if you'd rather not bother then you can simply throw another port in the daemon_smtp_ports list and use that instead of 25 for regular old insecure SMTP.
     
  10. JohnNicks

    JohnNicks New Member

    Have you tried calling ATT and asking them to remove the SMTP Power 25 restriction on your account?

    I have had a friend that wanted to use his own domain for sending email and called them and they removed it and it works just fine..
     
  11. BAlGaInTl

    BAlGaInTl New Member

    I may give that a shot, but I would really like to secure things as well, so I'm going to keep looking in to that.
     

Share This Page