Gallery1 Needs Exec() enabled

Discussion in 'Linux VPS/Dedicated - cPanel' started by Robert, Apr 14, 2011.

  1. Robert

    Robert New Member

    I have been looking all over for my answer before creating a new thread. I tried putting an empty php.ini file within the directory of PHP scripts for my gallery1 install. I want to keep everything as secure as possible, but I really need this to work as I have several gallery1 installs, and prefer Gallery 1 over versions 2 and 3 in most cases. The Exec() I assume is for NetPBM and/or ImageMagick.

    Can someone tell me what I need to do to get this to work for only certain vhosts? I found a good link via Google, but I'm not sure what is best for me to follow on my cpanel VPS.

    Thanks in advance for any help you can give me or point me in the right direction.

    P.S. the /setup/ php WEB UI tells me that PHPs Exec() is enabled, and that is good, however there's an error at the top that says "Warning: exec() has been disabled for security reasons in /path/user/website.com/lib/setup.php on line 808"
     
  2. Dan

    Dan Moderator

    Hello Robert,

    It looks to me like Gallery is the one that is disabling it from the error you are seeing because that looks like Gallery's installer that is giving you the message. Does the install complete and everything work?
     
  3. Robert

    Robert New Member

    Sorry for the delay in getting back, and lack of necessary details in my original post. I ended up emailing support and they enabled exec() for me. I am currently transferring from my old VPS (also hosted at KH but lacking Cpanel) to my new VPS with cPanel. I certainly appreciate the over-secure feel of the new VPS over the old one. So the "setup" in the path is to try and get things back on track.

    I think my issue(s) are somewhat resolved. I'm still having problems with my gallery, but I think it's due to open base dir, which I know I can find the answer around here somewhere.
     

Share This Page