galera Issues managing mariadb galera cluster


New Member
Hi Guys,

I set 3 nodes mariadb galera cluster,and also installed and setup haproxy,and tested ,it worked fine (after troubleshooting

and fixing issues which came)

now while testing i was bringing down nodes one by one,first node3 ,then node2 and then node1,intially it was working

fine,working on other nodes
then i shutdown node1 and node2 and brought up only node3
suddently first haproxy gave error for handshake /connections issue

then i closed haproxy and checked nodes ,on all node mariadb and cluster went down and not coming up ,i tried many times on

node3 to bring up mariadb,it was not working,then i brought up both nodes
and tried to bring up mariadb and galera cluster from node1 ,node2 ,node3 but not worked
then tried as below

1)from node 1 tried sudo /usr/bin/galera_new_cluster,not worked
2)then in /var/lib/mysql/grastate.dat on node 1 ,changed safe_to_bootstrap: 0
from 0 to 1 ,still not worked,then repeated from node 2 and node3 also still not worked
3)from node 2 and node3 also tried to start using -galera_new_cluster
but not worked

any suggestions please reply what is wrong and on day to day working and galera management comment on below

a)what are filesystem for mariadb and galera on local filesystem (non storage)
b)best practises
c)best way to start stop galera and mariadb once setup