FTP Question

Discussion in 'Linux VPS/Dedicated - cPanel' started by Nalco, Oct 22, 2007.

  1. Nalco

    Nalco New Member

    I have a dumb question for ya.

    How can access the root files via FTP?

    For example, I wanted to FTP in and grab the php.ini file so I could make a few edits and then dump it back up to the server. I needed to get to the usr/local/ directory, but couldn't get high enough.

    I wound up accessing the file through VZZP, but was wondering if this possible via FTP. I use FlashFXP if that matters.

    Thanks!
     
  2. Jleagle

    Jleagle New Member

    Use an FTP program like WinSCP
     
  3. khiltd

    khiltd New Member

    The application you use has no bearing on what you're allowed to see. Login as root and you'll have root access regardless of the software involved. SFTP would be a much better idea, however.
     
  4. Nalco

    Nalco New Member

    Thank you very much!

    Worked like a charm!
     
  5. ppc

    ppc Moderator

    Nalco,

    Everyone suggestions here are correct. The reason khiltd suggested using the SFTP protocol is because it is run on a secure channel where it encrypts both commands and data.

    Regards,
     
  6. Jleagle

    Jleagle New Member

    Hmm, i didnt know you could do this with any old FTP program.. Ive always used WinSCP because i thought i had to.
     
  7. magic

    magic New Member

    That is not correct. By default the root user cannot log in using FTP. You have to use SFTP or SCP for security reasons.
     
  8. khiltd

    khiltd New Member

    I honestly don't think I've ever even tried it, but good to know.

    If there were anything magical about that client those of us who don't use Windows would certainly be out in the cold.
     
  9. jcurioca

    jcurioca New Member

    Edit the file from cpanel tools

    Edit the file from cPanel tools. Is easy.


    Jorge Curioca
    <snipped>
     
  10. ppc

    ppc Moderator

  11. naichunlei

    naichunlei New Member

    I've the same question.
    I'm using Fillezilla.
    I tried to set it up on filezilla by using these parameters:

    Host: my primary ip address
    Port: 2200
    Server type: FSTP using SSH2

    User: root
    Password: **********

    Here's the log:
    Status: Connecting to 72.249.28.69:2200 ...
    Status: Connected with 72.249.28.69:2200, initializing SFTP connection...
    Command: CONNECT [email protected]:2200
    Response: Fatal: Unable to authenticate
     
  12. naichunlei

    naichunlei New Member

    I managed to get it work on WinSCP anyway... but not on normal FTP client like Fillezilla...
     
  13. khiltd

    khiltd New Member

    asiandvdcovers.com? You might want to re-read the acceptable use policy before your account gets terminated since I'm 99% sure you don't have the legal right to reproduce or distribute any of that stuff:

     
  14. naichunlei

    naichunlei New Member

    :confused:
    I wonder how did you relate that website to me??? That wasn't my website :rolleyes:
     
  15. khiltd

    khiltd New Member

    If that's not your IP then that would probably explain why you couldn't login.
     
  16. naichunlei

    naichunlei New Member

    That is my IP. I did manage to connect using WinSCP using the same parameter.
    How am I connected to this website :confused:
    We are a company based in Paris and there is no where we would like to be connected to these websites....
     
  17. Dan

    Dan Moderator

    I just ran a tracert on the IP listed and it resolved to a different address than the one you listed Khiltd.

    Although, naichunlei, you may want to put an index file or disallow directory browsing as I get a directory of your root folder when I pull up the site ;)
     
  18. khiltd

    khiltd New Member

    Well then perhaps a fluctuating DNS record is responsible for the problem, because I get:

    Code:
    nslookup 72.249.28.69
    Non-authoritative answer:
    69.28.249.72.in-addr.arpa       name = host.asiandvdcovers.com.
    
    Authoritative answers can be found from:
    28.249.72.in-addr.arpa  nameserver = ns2.khnoc.net.
    28.249.72.in-addr.arpa  nameserver = ns1.khnoc.net.
    ns1.khnoc.net   internet address = 65.99.213.7
    ns2.khnoc.net   internet address = 65.99.213.8
    
    Is this a new account that was just recently setup in the past day or so?
     
  19. naichunlei

    naichunlei New Member

    I'm completely lost :confused:
    But YES I just signed up 2 days ago.
     
  20. ppc

    ppc Moderator

    This is what I get. It must have been a cached record as KH Paul pointed out.

    Code:
     nslookup 72.249.28.69
    Server:         127.0.0.1
    Address:        127.0.0.1#53
    Non-authoritative answer:
    69.28.249.72.in-addr.arpa       name = host.omonsite.com.
    Authoritative answers can be found from:
    28.249.72.in-addr.arpa  nameserver = ns1.khnoc.net.
    28.249.72.in-addr.arpa  nameserver = ns2.khnoc.net.
    ns1.khnoc.net   internet address = 65.99.213.7
    ns2.khnoc.net   internet address = 65.99.213.8
    
    naichunlei,

    Are you still experiencing this issue?

    Regards,
     

Share This Page