forbidden in public_html

superman

New Member
Cannot open my domain when it comes this forbidden
this also in my public_html

Forbidden

You don't have permission to access / on this server.


how can i activate it? thank you
 

Dan

Moderator
Hello superman,

Is this after you've uploaded files or are you trying to browse the directory?

If it's after uploading files make sure you've uploaded them using the correct account (not root) so that they are owned by the correct user.

If you're trying to browse the directory, if I remember, cPanel defaults to directory browsing off. If you want to be able to do so then there should be a switch in WHM to turn it back on.

Additionally you can take a look at the Apache error log which should be at /usr/local/apache/logs/error_log.

Hope that helps!
 

superman

New Member
Hello superman,

Is this after you've uploaded files or are you trying to browse the directory?

If it's after uploading files make sure you've uploaded them using the correct account (not root) so that they are owned by the correct user.

If you're trying to browse the directory, if I remember, cPanel defaults to directory browsing off. If you want to be able to do so then there should be a switch in WHM to turn it back on.

Additionally you can take a look at the Apache error log which should be at /usr/local/apache/logs/error_log.

Hope that helps!
Hi Dan,

this my cPanel error log
[Thu Dec 15 19:42:43 2011] [error] [client xxx.xxx.xx.xx] client denied by server configuration: /home/myuser/public_html/

i believe it is because default browsing directory.
Which menu can i use in WHM to set it ON.

Thank you
 

Dan

Moderator
Hi superman,

That's actually a different error than you would get if directory listing were not allowed. The error for indexes would be similar to this: Directory index forbidden by Options directive.

Here is how to check for indexes: In the domain's cPanel go to the Advanced section and go to Index Manager. In there select Public_html then select what type of indexing you want. This simply modifies the .htaccess file which you can of course do manually as well.

However as I said before you seem to be getting a different error. Do you have mod_evasive installed? It has been known to cause errors like that to sometimes occur and then others not.
 
Top