Error in WHM after enabling/installing Munin

#1
Hey guys, upon reading Munin recommended in another thread on here, I logged into WHM and went to cPanel, Manage Plugins, and checked "Install and keep updated."

It seemed to have installed with no issue, but if I go to Plugins, Munin Service Monitor, I get this:

HTTP error 401
cgi/addon_munin.cgi

WHM is configured to disallow execution of unregistered applications when logged in as root or a reseller with the "all" ACL. To enable this functionality you must do one of the following: Register this addon using /usr/local/cpanel/bin/register_appconfig (http://docs.cpanel.net/twiki/bin/view/SoftwareDevelopmentKit/AppConfig), Enable the "Allow apps that have not registered with AppConfig to be run when logged in as root or a reseller with the "all" ACL in WHM" option in "Tweak Settings", or add permit_unregistered_apps_as_root=1 to /var/cpanel/cpanel.config, and run /usr/local/cpanel/etc/init/startcpsrvd
I'm at work and don't have my iPad with me to ssh into my VPS. Can this be fixed via browser? Or via console only? (sorry, I forgot how to potato...)

Thanks!
 

KH-Mathew

Systems Administration
Staff member
#2
Hey Nicki,

Enable the "Allow apps that have not registered with AppConfig to be run when logged in as root or a reseller with the "all" ACL in WHM" option in "Tweak Settings"
This is via WHM.
Send me a PM with your IP and I will check it out for you if you need me to.
 
Top