email with google apps problem

#1
I'm using google apps for my mail server on the domain shadyspring.net. It's been running great for a long time but I just realized that mail sent on my php based contact form is still going to my own server; its not forwarding to googles servers, thus I'm not recieving the email. This is verified with an email trace from cpanel which shows the path to be "virtual_aliases via /etc/valiases/shadyspring.net . My MX records are setup and email sent from anywhere else is routed correctly, just not my own server. How do I go about configuring my own server to route mail from my server (for this domain, I do have other domains with email hosted on this server) to google mail.
 

Dan

Moderator
#2
I had a similar situation and it is not possible as even though the server's been configured for remote domains when and email is generated locally it will not be sent offsite. You can confirm this by sending an email from one of your other domains to it.

I just did a mailto: opening up the user's mail client and they're happy. Can put the actual email address into a js file to mask it, works quite well.

Hope that helps
 
#3
Is this a cPanel only issue?

I haven't had any issues with DirectAdmin and google apps. There was a checkbox that I disabled for handling mail with the server.

I can send email using PHP, IMAP, or POP3 from any of my domains and it arrives properly at gmail.
 

wodin

New Member
#4
support desk

I decided to submit a ticket to the support desk and this was there reply below. It's working perfectly now. Thanx for the replies. Hopefully this will help someone else.

The domain 'shadyspring.net' was existing in the file '/etc/localdomains'. Hence whenever a mail is sent to shadyspring.net accounts, mail server will try for local delivery without checking MX records. We have now removed the domain 'shadyspring.net' from the file '/etc/localdomains' and added it to '/etc/remotedomains' which should resolve your problem.
 
#5
I decided to submit a ticket to the support desk and this was there reply below. It's working perfectly now. Thanx for the replies. Hopefully this will help someone else.
Glad that you got it resolved.

But now I'm wondering... is there a way to do this from cPanel for anyone who may have this problem in the future?

As I said, DA has a check box where you can enable or disable the MX server for the domain.
 

Dan

Moderator
#6
Glad that you got it resolved.

But now I'm wondering... is there a way to do this from cPanel for anyone who may have this problem in the future?

As I said, DA has a check box where you can enable or disable the MX server for the domain.
I have changed a number of domains over to Google Apps recently and cPanel has improved their MX record handling. If you move the local MX to a higher number it will remove the domain from /etc/localdomains and add it to /etc/remotedomains automatically.

I have tested sending an email between domains and it worked but I have not tested PHP mail or formmail.
 
#7
I have changed a number of domains over to Google Apps recently and cPanel has improved their MX record handling. If you move the local MX to a higher number it will remove the domain from /etc/localdomains and add it to /etc/remotedomains automatically.

I have tested sending an email between domains and it worked but I have not tested PHP mail or formmail.
Great to know that change is in place now.
 

Dan

Moderator
#8
Just sent email from Roundcube to another user on the same domain and it worked as well so I think that everything probably works just fine now :D
 
#9
Just sent email from Roundcube to another user on the same domain and it worked as well so I think that everything probably works just fine now :D
If you have Roundcube set up to send mail, aren't you still using the gmail SMTP server? If that is the case, the mails are still being sent from an external location.

I thought that is how I had mine set up.

Do you have a simple php script or something that you can use to test sending mail? I used a quick forum that I installed to test mine.
 

Dan

Moderator
#10
If you have Roundcube set up to send mail, aren't you still using the gmail SMTP server? If that is the case, the mails are still being sent from an external location.

I thought that is how I had mine set up.

Do you have a simple php script or something that you can use to test sending mail? I used a quick forum that I installed to test mine.
No, it's a custom install of Roundcube on the VPS configured to use the localhost. Just checked the header and it did indeed come from there.
 
Top