Email server configuration and SMTP not responding

Discussion in 'Linux VPS/Dedicated - General' started by Terry Frazier, Dec 5, 2014.

  1. Terry Frazier

    Terry Frazier New Member

    I have a few questions regarding my mail server configuration.

    1. SMTP: I am unable to send email via SMTP. I get a connection timed out error. In Service Configuration > Service Manager Exim SMTP is enabled and I receive emails generated from the system, but I cannot login to the server as a user with a normal mail client and send email. Where else should I look for problems?

    2. POP3 and IMAP: I posted this in another thread related to cPanel SSL enforcement but I am going to ask again here because it's specifically about email. I installed SSL certs on the server and set cPanel to require SSL logins. In Service Configuration > Mailserver Configuration there is an option for Allow Plaintext Authentication (from remote clients) and the default value is Yes. I think it should be No. The explanatory text for the option indicates No is the better setting and that it still allows webmail to work, so I think it is cooperative with the Require SSL setting in cPanel and extends the requirement to normal mail connections, which is what I want. Is this accurate?

    Thank you.
     
  2. KH-Dmitry

    KH-Dmitry Administrator Staff Member

    1) try a telnet connection to whatever ports your SMTP server listens on, for example

    telnet my.server.com 25

    if you are able to open a connection then next step would be exim logs, if not then check your firewall, another problem might be your ISP blocking connection to SMTP ports

    2) if you require SSL encryption then the username/password pair is submitted over an encrypted channel so plaintext authenticator is good. Generally at least some 'non-plaintext' authenticators are in my opinion less secure because they require your password to be stored in plain text form on the server (CRAM-MD5 for example). It also depends on your situation. If you are the only user then you can use whatever settings you wish. If there are other people then plaintext is possibly more safe since it is supported by any mailer.
     
  3. Terry Frazier

    Terry Frazier New Member

    Thank you very much for the response. I will leave the Plaintext setting to Yes for now.

    I am able to make SMTP connections to other servers, just not mine.

    When I telnet to port 25 I get the following response:
    220-We do not authorize the use of this system to transport unsolicited and/or bulk email.

    When I attempt to telnet to port 465 I get nothing. (I don't know what this means, or whether I can even telnet to port 465.)
     
  4. JoseDieguez

    JoseDieguez Member

    Also ports 26, 587?
     
  5. Terry Frazier

    Terry Frazier New Member

    I got a reply on port 26. I was able to clear up the problem. There was a loose nut between the steering wheel and the seat... ;-)
     
    JoseDieguez likes this.
  6. adev

    adev Member

    care to share in case anyone else is having the same issue? was it using port 26 that did the trick? ;)
     
  7. KH-Jonathan

    KH-Jonathan Director of Managed Services Staff Member

    That'd be my guess. Lots of ISPs block port 25 to the outside world and only allow you to use port 25 on their internal mail servers, hence port 26 on ours :)
     
  8. Terry Frazier

    Terry Frazier New Member

    Oh, hell no. It was a completely stupid user error. My user error. The port setting box in the mail client is small, and the text next to it says Default Port: 465. I had already set it to 465 but through some combination of fumble fingers, bad luck, wonky mouse button or whatever it got set to 1. Every time I looked at it after that I saw the "465" but not the "1". In my exchanges with tech support, who were quite patient with my idiocy btw, I decided to send them a screen shot of the settings but before I did I enlarged it to look at. You know, just to be sure I wasn't wrong.

    And I was. ;-) I might have to get some glasses...
     
  9. adev

    adev Member

    Exactly what I as thinking Jonathan.

    Oops terry, but we've all been there at some point.
     

Share This Page