Email errors

Discussion in 'Linux VPS/Dedicated - cPanel' started by AlexH, Feb 13, 2014.

  1. AlexH

    AlexH Member

    Hey all! I recently started having problems sending mail from my KH VPS. Here's my problem and what I've tried so far:

    PROBLEM: The following errors are received when sending from SMTP or a PHP mail function from my_domain.ORG TO my_domain.ORG. This also happens from webmail on my_domain.NET

    "lowest numbered MX record points to local host"
    "temporarily rejected RCPT: Could not complete sender verify."

    Here's my setup:
    mydomain.NET is an account on my VPS. It's using internal DNS and the http traffic works fine. I can send email to most domains just fine.

    mydomain.ORG is an account on my VPS. It's using external DNS set up by IT at my organization. All A record traffic is sent to my VPS IP address. The MX record points to our in-house Microsoft Exchange Server.

    Again, this problem happens when I'm sending mail from my_domain.ORG to my_domain.ORG (some of my PHP applications use php mail and some use SMTP using the my_domain.NET domain).

    Here's what I've tried:
    1) I noticed my IT department didn't have host.my_domain.ORG DNS set up. It now resolves to my VPS IP address.

    2) I tried:
    #Login to the WebHost Manager.
    #On the Service Configuration section,click on Exim Configuration Editor link.
    #Uncheck and untick the checkbox next to Use callouts to verify the existence of email senders. option.
    #Press the Save button, and cPanel will auto restart Exim.

    Did not work.

    3) I tried
    # Go to /etc/localdomains and place my_domain.ORG entry there. There is no need to restart the ‘exim’

    Tried this, but it didn't work. I restored it back to what it was before.
     
  2. Dan

    Dan Moderator

    Morning AlexH,

    Ok so let me see if I have this straight.

    *.ORG has an account setup locally but no email accounts (causing the error you receive).
    *.ORG's DNS is on a remote server as are all email accounts.
    I'm assuming that DNS on the localhost (your VPS) has not been configured at all since the actual DNS is remotely hosted.

    Yet the localhost thinks it's the hosting the DNS because it has the account on it.

    Configure the DNS on your VPS for the remote email server and change the priority of the MX records. After making these changes let it automatically detect whether it's the MX master and it will set everything correctly. Don't delete the MX record for the VPS completely and then it will act as a backup email server for when your remote email server has trouble. Create no accounts on the VPS either as if you do email will be routedinto those accounts rather than being queued then spooled off to the remote server when it comes back up.

    I have a domain with remote email server as well and when I originally set it up (quite some years ago now) cPanel was not very good at changing everything it needed to. The only way I could get email sourced on the server using a script or something was by making manual changes. However I think they have gotten it down much better now.

    I do think that what I said is the issue. Your VPS thinks it's the email host and yet there are none of those accounts set up on it.

    I would configure both DNSs the same myself. Make a change on one then make it on the other as well. You could try setting up a master/slave relationship between the two although I don't know if that can be done for one specific domain.

    Hope that helps!
     
  3. AlexH

    AlexH Member

    Thank you so much Dan for your response. I just remembered that I didn't reply & wanted to tell you that your post was quite helpful.

    The DNS zones needed modification just as you suggested and I got it worked out!
     
  4. Dan

    Dan Moderator

    No worries Alex, glad to hear you got it sussed out!
     

Share This Page