centos 6 with x windows system

Discussion in 'Linux VPS/Dedicated - cPanel' started by acidrain, Aug 20, 2015.

  1. acidrain

    acidrain New Member

    Can some one explain when installing a gui/vnc/gnome what ever you want to call it WHY does it kill your outbound internet? For example I can vnc or SSH in but if i'm at the command line ping google.com will not work, I get unknown host google.com. I can't yum install anything, I can't use firefox etc. HOW DO I GET MY INTERNET CONNECTION BACK?

    thanx
     
  2. phpAddict

    phpAddict Active Member

    Can you ping IPs? Such as ping 8.8.8.8 (google's dns server)
    You may need to configure a DNS server in your network settings.
     
  3. acidrain

    acidrain New Member

    I can ping 8.8.8.8 but can't ping websites.

    You may need to configure a DNS server in your network settings. ----> HOW?
     
  4. acidrain

    acidrain New Member

    When the vps is first created everything works fine. Once I put the GUI on I like to know WHY IT HAS TO DESTROY THE INTERNET CONNECTION OR WHAT CAUSES THE CONNECTION TO DIE. I have spent ages to get the answer on this. I like to know what i am doing wrong? It's very very frustrating just trying to do one simple little thing.
     
  5. KH-Jonathan

    KH-Jonathan Director of Managed Services Staff Member

    We don't recommend or really support installing X and a DM on a VPS. It's surprisingly resource intensive and almost always results in an abuse ticket. Something as simple as FireFox can be quite RAM intensive and run you into corruption issues for other servers getting killed due to lack of RAM before you know it.

    As for your actual technical question, installing a GUI should have no effect on networking.
     
  6. KH-Paul

    KH-Paul CTO Staff Member

    Sounds like one of the tools you have installed might have changed the /etc/resolv.conf file. You can just reboot your VPS to reset content this file back to its original state. If you don't what to reboot something like following should help:

    Code:
    echo "nameserver 127.0.0.1" > /etc/resolv.conf
    echo "nameserver 8.8.8.8" >> /etc/resolv.conf
    echo "nameserver 8.8.4.4" >> /etc/resolv.conf
    
     
  7. acidrain

    acidrain New Member


    here is what or at least what I think is correct way of doing this... I have tested this on another VPS the gui works but the internet connect, outbound does not aka can't ping domain names only ip addresses.

    sudo yum groupinstall Desktop
    sudo yum install tigervnc-server
    sudo yum install xorg-x11-fonts-Type1

    configure VNC

    nano .vnc/xstartup
    add/delete
    #twm &
    exec gnome-session &

    after everything is working I can still ping domain names, yum updates etc. Reboot there goes the internet connection.

    Is there a better way to load the gui? I tried previous solution and nothing and still no internet connection.
     
  8. acidrain

    acidrain New Member

    I finally figured it out. When you install
    sudo yum groupinstall Desktop

    it turns on a network manager and everytime the system is rebooted it rewrites the /etc/resolv.conf file.

    service NetworkManager stop
    chkconfig --level 12345 NetworkManager off

    seems to fix that problem only took me a year to figure that out.

    as for the "abuse" issue the GUI it self does not take up much cpu power. Running/installing/updating/compiling cpanel sucks up more cpu power. I've seen my averages go into 5.5 range on that. Even running shoutcast servers don't even take up that. But running browsers (which i don't understand why you would) is CPU intensive.

    Speaking of cpanel can some one explain why it is a memory hog? For example if I'm in the GUI my memory gets eaten up very fast. After a while it will go down to a degree but not to where it's supposed to be at a reasonable level.
     

Share This Page