Apache user is "nobody"? Wordpress permissions issue

Discussion in 'Linux VPS/Dedicated - cPanel' started by Robert.S, Jul 5, 2010.

  1. Robert.S

    Robert.S Guest

    Hi there - quick question:

    I'm wanting to use "automatic upgrades" in Wordpress installed on one of my accounts, but it defaults back to a slow ftp-option.

    This is because WP is expecting that the script (Apache) executing has the same ownership as the Cpanel account.

    EDIT: Here's an explanation - sorry I know its a Wordpress issue but it has to do with how your host operates: chrisabernethy.com/why-wordpress-asks-connection-info/

    On my other VPS (read: competitor to knownhost, that I will be migrating from to knownhost later this year!), Apache runs as the account owner, but on Knownhost Apache runs as "nobody".

    Is this correct?

    Can I change it?

    I've tried changing permissions (temporarily) on the WP directories but that doesn't seem to work, I also tried changing owners in Virtuozzo to see if that gave any clues but I fearful of stuffing something up and need some guidance (since I'm not a programmer but an admin!)

    Appreciate some direction or hints if you have them ..

    Robert
     
  2. inveress

    inveress New Member

    Hi Robert,

    I believe you need to add suPHP into your Apache build. This allows Apache to execute PHP scripts as the account owner.

    Peter.
     
  3. Robert.S

    Robert.S Guest

    Hi Peter - yes that's the conclusion I've come to and it will be my next step! Being a bit of a self-taught webmaster has its limitations ... I was not sure if I should do that rebuild ... ;) I already seemed to have stopped Fantastico from working ... grrrr
     
  4. Robert.S

    Robert.S Guest

    UPDATE: Yep, re-compiling Apache from WHM using the "basic" option adds in an option for suphp which once selected, fixed my issue completely.

    It did manage to stuff around Fantastico, but I was able to SSH to root and run /scripts/makecpphp and then had to select iocube as cpanel php loader ... everything now working as it should running smoothly.

    Thanks for the help Peter. (I'm on the Sunshine Coast btw)
     

Share This Page