Apache error after updating to WHM 11.40

Discussion in 'Linux VPS/Dedicated - cPanel' started by Dan, Nov 6, 2013.

  1. Dan

    Dan Moderator

    If you run into the following error after updating WHM to version 11.40 then you simply need to run EasyApache to fix it. Essentially it looks like they are adding support for IPV6 and due to the old httpd.conf not supporting it you get this error when trying to run the apache_conf_compiler.

    Code:
    [Wed Nov 06 09:34:36 2013] [crit] (EAI 9)Address family for hostname not supported: alloc_listener: failed to set up sockaddr for ::
    
    Configuration problem detected on line 170 of file /usr/local/apache/conf/httpd.conf.work.PsABU7IkikfQtoi0:     Listen setup failed
    
            --- /usr/local/apache/conf/httpd.conf.work.PsABU7IkikfQtoi0 ---
    
    There was more but I've truncated it to just show the error the first time it shows.
     
  2. jnicol

    jnicol New Member

    Thanks for this info! I ran into the same error when using WHM's Include Editor (Service configuration > Apache configuration > Include editor).
     

Share This Page