Anyone gotten Drupal Drush running on CentOS?


New Member

I have a two Drupal sites: a Drupal multisite installation and another standalone Drupal install on a CentOS VPS. I have followed the instructions to the letter, but I cannot get Drush to run.

Has anyone been successful installing and using Drush on a CentOS VPS? Any tips you can share would be helpful.
Working for me

I ran across your post while looking up some issues I was having with drush. While I bit dated I figured it might help others to post.

I didn't have a problem actually getting drush to run. I downloaded the latest version, unpacked to a shared location (/usr/share/drush will do). You then need to chmod /usr/share/drush/drush so that it has executable permissions (chmod u+x /usr/share/drush/drush). After doing that you can run drush but it will serve you better to either add drush to your path or make a link to it in a place where your current path will pick it up. For example, you can run something like ln -s /usr/share/drush/drush /usr/bin/drush.

I run my VPS with Knownhost and used SSH to install/run. If you don't have SSH access you won't really be able to run drush let alone install it as it's a command line tool.