Advice before enabling mod_ruid2

DennysR

New Member
Hi,

My VPS is currently configured for php5, DSO and suEXEC and I'm wanting to change it to mod_ruid2.

I've done a lot of searching (here and other sites) and cannot find an answer to my specific questions.

Since I've been running with DSO as my php handler I have files owned by nobody:nobody and directories and a few files set to 777. Do I need to chmod the directories to 755/files to 644 and chown the files in the home directories to owner:eek:wner before running EasyApache or can I do that after enabling mod_ruid2?

Are there any other things I should do before switching to mod_ruid2?

TIA,
Dennis
 

KH-DanielP

KH-COO
Staff member
@DennysR

You will indeed have to change the owners and permissions. Owners need to be user:user and permissions 755 for folders and 644 for files.

There is a nifty script that can do this for you located here:
http://boomshadow.net/tech/fixes/fixperms-script/

It's built for suphp and fastCGI but works also for mod_ruid2

I'd go ahead and re-compile mod_ruid2 and then run the permission correction script and you'll be good to go. If you run into any issues don't hesitate to open a support ticket with us.
 

DennysR

New Member
Thanks for the quick answer to my question and the link to the script. I'll let you know how it goes after I make the switch and hopefully, I won't have to create a trouble ticket.
 

DennysR

New Member
Update: I ran EasyApache in WHM with the mod_ruid2 option selected. It ran about 10-15 minutes and completed.
I then used the sh fixperms script Daniel directed me to and ran it in ssh.
Result: Everything works perfect (and seems a little snappier, but it's hard to tell since my Knownhost VPS always runs snappy.)

One last thing I noticed: I was getting a consistent PHP fault error from my forum software in the system error log. I could not track down the source of the problem after digging though files for a couple of days. That error is gone now. I can only assume it was something owner/permissions based creating the error condition.

Thank You
 
Top